0

I have Windows Thin Clients on the network that are not Domain joined. They access a Domain joined terminal server. If I use RDP and enter the server name, then when prompted, user credentials they cant login. If I login with this format domain\user for the username, it will connect. I want the RDP sessions to login with the regular credentials, not extended ones as it adds confusion with the end users.

I know it can be done as I've used it this way before, I've just never been the one to set it up until now.

The Terminal Server is 2012r2 with WES7 clients.

Thanks, Travis

  • I want the RDP sessions to login with the regular credentials, not extended ones as it adds confusion with the end users. - So they're trying to login with a username of John instead of Domain\John and that fails? – joeqwerty Jun 21 '16 at 19:31
  • That is correct. – TMacie Jun 21 '16 at 19:47
  • You can quite easily create an RDP link that automatically populates the domain so users don't have to enter it, then copy it to each thin client. – Naryna Jun 21 '16 at 20:51
  • @BrandynBaryski - see below. – TMacie Jun 22 '16 at 12:09
0

Let's try this the most obvious way I've done with thin clients before. You can actually save an RDP link with the appropriate credentials already populated, in this case the domain name.

Saving your RDP link

As per the image you can see that we have added in our server address and the domain name and the slash. Now, we save the link somewhere (ideally a flash drive). You can now distribute your custom link to all the thin clients. Fast and easy.

  • This is the way I have it now, but occasionally someone goes in and deletes that, then cant log on until the TC is rebooted. I want to avoid using that method. – TMacie Jun 22 '16 at 12:08
  • @TMacie Are they actually going in and editing the connection file instead of just running it? If you have it written the way I do above, it should give them a username and password option, but the domain name should not be able to be changed. I'll admit, I forget which RDP version WES7 uses, but the versions I have don't allow the domain name to be changed. Is kiosk mode an option? If it is, you can always automate the connection process. – Naryna Jun 22 '16 at 15:16
  • I don't know if they are doing or if it loses config once in a while, but either way I know it can be done so I don't have to worry about any of that. I'm not able to ask the person who had it working at the last place, either. Kiosk mode isn't an option, they need to log into the Terminal server as themselves. Thanks though! – TMacie Jun 22 '16 at 18:03
  • I'd honestly suggest this is a user training/user incompetence error then. Your users are either editing the connection file or bypassing it directly to access mstsc manually and typing in the server address themselves. The former can be fixed by editing the connection file properties (Unless you are letting your thin client users log in as the administrator rather than the user), but fixing the latter is troublesome on a thin client. Besides that, this is best fixed by training at that point. – Naryna Jun 22 '16 at 22:28
  • I agree there. I just know that its been setup the way I've suggested in my question before and if I can duplicate that setup I can eliminate any training/incompetency issues. – TMacie Jun 23 '16 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.