0

Operating System - Windows 2008 R2 Service Pack - Service Pack 1 IP Address - 10.50.1.111 Subnet Mask - 255.255.255.0 Gateway - 10.50.1.1 DNS Server - 10.50.1.90

Other servers are using 10.50.1.90 as their DNS server and are not having any problems. This tells me that the problem is not with the DNS server.

I can ping 10.50.1.90.

The firewall is disabled.

If I run nslookup and query the name of 10.50.1.90 (OfficeDC1.office.org) it says, "*** [10.50.1.90] can't find OfficeDC1".

If I run nslookup and change the server to 8.8.8.8 and query google.com it says, "*** [8.8.8.8] can't find google.com: No response from server".

Any thoughts?

0

Have you tried restarting? Or specifically restarting the service?

ipconfig /flushdns

and restart DNS Client service?

  • Yes. msconfig shows that it is configured to start normally. The DNS Client service is running. The DNS cache has been flushed and registered multiple times over the course of 6 hours. The server has been restarted twice. – user5870571 Jun 23 '16 at 19:37
  • You said that you changed the local machines DNS server to 8.8.8.8 and saw the same issue? – Tony DeJesus Jun 23 '16 at 19:48
  • I did not change the DNS server configuration on the NIC, but I opened nslookup and manually changed the DNS server for the session in nslookup to 8.8.8.8. Yes the issue was the same. – user5870571 Jun 23 '16 at 19:49
  • @user5870571 use debug option and then show result. For example: nslookup --> set debug --> server 8.8.8.8. (or 10.50.1.90). If you have "DNS request timed out. timeout was 2 seconds. timeout (2 secs)" This means that you can not access the DNS server on port 53. – stambata Jun 23 '16 at 20:14
  • The server has since been shut off but it should be back on tomorrow. I will give that a try and let you know what the results are. – user5870571 Jun 23 '16 at 20:17
0

In this case, the problem had nothing to do with DNS. The problem was the TCP stack was corrupted. I uninstalled and reinstalled the network adapters and ran the command below.

netsh winsock reset

After the command ran I restarted the server and the DNS problems were resolved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.