I'm using a server of OVH with OS centos7. OVH has its own linux kernel:


Now I try to configure another Centos7 kernel. I installed the other kernel(s).

yum install kernel

ls /boot shows me

System.map-3.10.0-327.22.2.el7.x86_64  bzImage-3.14.32-xxxx-grs-ipv6-64   efi   grub2                                     symvers-3.10.0-327.22.2.el7.x86_64.gz
System.map-3.14.32-xxxx-grs-ipv6-64    config-3.10.0-327.22.2.el7.x86_64  grub  initramfs-3.10.0-327.22.2.el7.x86_64.img  vmlinuz-3.10.0-327.22.2.el7.x86_64

Now I want to configure to use 3.10.0-327.22.2.el7.x86_64. On some tutorials I found to edit grub.conf but this doesn't exist. I found grub.cfg in the grub2 folder. What do I have to edit inside that .cfg to configure my new kernel? All the tutorials are showing configurations for the older grub.conf.


3 Answers 3


I've been wasting several hours too on that problem, and finaly I found out what was going on : I'm partially blind... OR the interface is not working well sometimes.

First, when you use an OVH template to install your centos, just before the last confirmation, you have the possibility to clic "install the original kernel", just between "installation URL" and the "SSH Key" choice.

If you don't select that option, then by default, you'll systematically boot by the network the 3.14 grs kernel, which makes the changes in grub useless since it's not charged at all at runtime.

So either you select that option during install process, either you can choose afterward the way you boot in the backoffice->General information->Boot->modify->boot on hd.

Could be enough (good idea to start a console to see what happend during the boot sequence).

If not enough, then you'll have to change the default kernel in grub2.

First, print the choices you have :

$ grep '^menuentry' /boot/grub2/grub.cfg

(the first result is 0)

Open /etc/default/grub with a text editor, and set GRUB_DEFAULT to the numeric entry value for the kernel you chose as the default, for exemple the first result :


And then re-generate GRUB configuration.

$ sudo grub2-mkconfig -o /boot/grub2/grub.cfg

You're done -> reboot

Thanks that link

Hope it helps, enjoy !


After you install the OS distribution's kernel on your dedicated server, you must reconfigure it to boot from the hard drive instead of from OVH's kernel. This is done in your OVH management pages. It should look like the following:

OVH management page

  • yup, this worked May 27, 2017 at 17:13

Watch out for OVH's static motd. It caught me out for a bit.

They generate it with the kernel name but it wont update when you update the kernal for example to elrepo mainline.

If you run uname -a, you'll see that it's different.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .