0

I have basically read some kilometers of documentation and I still can't enable LDAPS on AD LDS...

I installed a self-signed certificate and a certification authority following for instance this link : http://www.cisco.com/c/en/us/support/docs/security/firesight-management-center/118761-technote-firesight-00.html. Note that I just want to run it on the AD for testing (so it is on the same machine).

I probably miss something, I'm quite sure this is so simple but it is dead annoying to troubleshoot...

Actually what I want to do is to authentificate users of my AD with a PHP script running on a IIS server, which is functional for LDAP but not with SSL/TLS (I'm sure this script is correct) with a ldap_bind() error.

I succeeded in enabling https but it seems it is still misconfigured since LDAPS doesn't work (there is an "auto configuration" for https).

Any clear solution :(?

  • What's the ldap_bind() error? Are you sure whatever library your PHP script uses actually uses LDAPS and not STARTTLS after connecting using plain LDAP? Have you tried to bind to your LDAP server using other tools? ldap-utils from a nearby GNU/Linux system for instance, or some external (Windows, GUI) tool such as ldapadmin or Apache LDAP Studio or whatever? – kostix Jun 28 '16 at 18:31
  • Warning: ldap_bind(): Unable to bind to server: Can't contact LDAP server in C:\inetpub\wwwroot\epic\ldapsconnector.php . Actually, LDAPS in PHP in no different than LDAP (which is OK), I tried the TLS with port 389 and starttls and the SSL with port 636. I think this is a certificate error, even if my IIS is well configured (I installed the CA and I'm quite confident my SSL certificate is correct), but LDAPS might require something else to be enabled. I can directly connect in ldaps to the instance but when I try to bind a user with ldp.exe it fails. – user361046 Jun 29 '16 at 8:56
  • Actually, it only fails if I select "bind with identification informations", it works if I select a simple bind with SSL. When connecting directly, I see "Hosts supports SSL", I don't know if LDAPS is finally right without IIS/PHP (even without SSL, I can't bind with the "bind with identification informations"). When connecting through IIS, I get a 48 TLS error which means my CA/certificate is not trusted, despite IE says me both my CA and my SSL certificates are valid. – user361046 Jun 29 '16 at 9:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy