2

I installed Centos7 onto a box we have here for testing, I am using a Bootable HDD to install it on the System, I have used the same HDD to install Centos7 on a Dell Powerblade Server & a HP Z640 System but it will not install on this Tyan Box for some reason.

Box Specs

Previous Operating System Windows 10 Pro 64-bit

CPU

CPU 1 Intel Xeon E5 v3 @ 2.40GHz Haswell-E/EP 22nm Technology

CPU 2 Intel Xeon E5 v3 @ 2.40GHz Haswell-E/EP 22nm Technology

RAM
64.0GB Unknown @ 931MHz

Motherboard
TYAN FT77C-B7079 (SOCKET 0)

Graphics
Standard Monitor (1024x768@60Hz)
ASPEED Technology Microsoft Basic Display Adapter (ASPEED Technology)
8x NVIDIA GeForce GTX 980 Ti 2047MB (PNY)
ForceWare version: 361.91
SLI Disabled

Storage 238GB Samsung SSD 850 PRO 256GB (SSD) 25 °C

The install appeared fine, went through the usual steps and rebooted. after reboot it runs through POST and gives me two options

I have multiple options in the BIOS under Boot options. BIOS Boot Options

I have swapped the order of each one multiple times, Booting form UEFI OS:, SATA0 PO:, and CentOS Linux (PO: SSD......

Each one has the same outcome, i get to this screen below. OS Options

Choosing EITHER of the above options results in the same outcome, a black screen and nothing comes from it, no errors, no cursor, nothing.

Edit - Picture of the exciting black screen. enter image description here

I have SecureBoot Disabled already. Secure Boot

I cannot get a terminal, I have tried Alt+F1, Alt+f2, Ctrl-Alt+F1, Ctrl-Alt+F2, ESC etc..

I have also re-installed twice, I also tried using the "Troubleshoot" option and install with basic GUI but had the same result.

I have seen multiple questions similiar to this on here but the difference is they could all access the Terminal, I unfortunately can't, or at least if I can, I'm not sure on how.

  • My guess is a driver issue. Did you download the DVD version of CentOS? Have you also tried not using the graphics card? – Jason Jun 28 '16 at 14:33
  • @FrankThornton that was my assumption, i downloaded the "Everything ISO" and installed "Gnome Desktop" with nothing added, the Boxes don't have integrated on-board graphics so using the GPU is the only way to actually install unfortunately – RyanIG Jun 28 '16 at 14:38
2

I've found the solution. note this post is based on this thread from this debian forums thread. I've had the same problem (except I couldn't even install initially). My install problem was that Nouveau prevented me from continuing past a certain point in the install. I fixed this, and then wasn't able to boot up. In my situation it would mostly black screen, but some times it would just freeze at the four penguins logo. This problem was also caused by Nouveau. I fixed this via the following steps:

  • press e before entering any centos boot.
  • navigate to the linuxefi /images/pxeboot/vmlinuz... line or what ever line is your linux boot command (usually ends in quiet to supress debug info)
  • enter in the following additional arguments to your boot args list:
    • rdblacklist=nouveau
    • nouveau.modeset=0
  • these arguments will stop nouveau from starting for the next boot, press ctrl-x or f10 to boot into Centos 7
  • uninstall nouveau and install non nouveau drivers, other wise you will have to do this process every boot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.