I have a problem with fuse sshfs and the running Sophos Antivirus Scanner for Linux Systems v9.11.0. I am running as OS RHEL7.1 with fuse-sshfs-2.5. The mounting via sshfs works fine when Sophos is disabled, but when the daemon is running the sshfs mount command hangs (forever). If I try to access the mounted directory with Dolphin, Dolphin itself gets stuck. I have tried to add several exceptions to Sophos (exclude directory from scanning, exclude filesystemtype fuse.sshfs) but nothing had worked.

Unfortunately we need to run Sophos, can't turn it off or use a different scanner. Maybe some knows a solution to work-around? Maybe I missed an additional option on the sshfs mount command?

I really appreciate any help you can provide.


If you are using auditd, unfortunately you are stuck: Fuse + auditd + Talpa = dead-lock.

You could try fanotify (since you are on RHEL 7), which avoids the deadlock.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.