0

In a small Remote Desktop Server farm (2x 2008 R2 session hosts + 1 session broker with IP address redirection) of a large-ish domain, we noticed a change in behavior which is giving us headaches:

Previously, the RD session broker only did balance / reassign connection attempts to existing sessions when we were connecting to the RD farm's name ("rdfarm-generic"). Connecting to a specific session host by its DNS name or IP address did ensure that you were actually connecting to this specific host.

For an as of yet unknown reason, this has changed so that connecting to a session host in any possible way would get users reconnected to an existing session (if any). So a simple mstsc /v:192.168.21.85 (192.168.21.85 being the IP address of RDSH-02) gets me redirected to the other member of the farm if I have a session there already. This is what the series of events on the connection broker looks like in such a case:

TerminalServices-SessionBroker/800
RD Connection Broker received connection request for user AD\the-wabbit. 
Hints in the RDP file (TSV URL) = tsv://MS Terminal Services Plugin.1.rdfarm-generic 
Initial Application =  
Call came from Redirector Server = rdsh-02.ad.example.com
TerminalServices-SessionBroker/803
RD Connection Broker has successfully determined the end point for this connection request. 
Endpoint name = rdfarm-generic 
Endpoint type = Farm 
TerminalServices-SessionBroker/807
RD Connection Broker has found a disconnected session for user (AD\the-wabbit) with session ID (9) on end point (rdsh-01.ad.example.com). Load balancing will be skipped.
TerminalServices-SessionBroker/801
RD Connection Broker successfully processed the connection request for user AD\the-wabbit. Redirection info: 
Target Name = RDSH-01 
Target IP Address = 192.168.21.82 
Target Netbios = RDSH-01 
Target FQDN = rdsh-01.ad.example.com 

Why is it happening? How do I get the old behavior back?

  • For all users or administrators? – Greg Askew Jul 1 '16 at 12:37
  • @GregAskew for all users. But in particular, it makes administration attempts through the remote desktop client a game of chance :-) – the-wabbit Jul 4 '16 at 8:14
  • mstsc /admin should work for administrators. – Greg Askew Jul 4 '16 at 12:39
  • @GregAskew it does, thanks. I am still trying to find out the root cause, though. For one reason or the other, one of the remote apps which is not easily installable elsewhere is only present on one of the hosts. So far, RDP files targeting the specific session host worked fine - up until some weeks ago. – the-wabbit Jul 4 '16 at 13:29
  • That is the expected behavior - you should be able to connect to any of the RDP host and get redirected per the broker decision. Why it wasn't doing that before is what is strange. Just a thought - never tried, maybe the "participate in connection broker load balancing" wasn't checked before? – ETL Nov 23 '16 at 18:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.