1

Has anyone experienced this? Recently I recreated our MDT environment from MDT 2012 to MDT 2013 U2. When I create an offline media, the installation process fails just after the "Format and Partition Disk" step, which means, that the "Copy Scripts" step fails. The disk gets formatted though. Normally when LTICopyScripts.wsf runs, it leaves a log behind. This does not happen. The smsts.log has this:

Expand a string: cscript.exe "%SCRIPTROOT%\LTICopyScripts.wsf"  TSManager   30-06-2016 09:11:13 272 (0x0110)
Expand a string:    TSManager   30-06-2016 09:11:13 272 (0x0110)
Start executing the command line: cscript.exe "%SCRIPTROOT%\LTICopyScripts.wsf" TSManager   30-06-2016 09:11:13 272 (0x0110)
!--------------------------------------------------------------------------------------------!  TSManager   30-06-2016 09:11:13 272 (0x0110)
Expand a string:    TSManager   30-06-2016 09:11:13 272 (0x0110)
Executing command line: cscript.exe "%SCRIPTROOT%\LTICopyScripts.wsf"   TSManager   30-06-2016 09:11:13 272 (0x0110)
Process completed with exit code 1  TSManager   30-06-2016 09:11:13 272 (0x0110)
!--------------------------------------------------------------------------------------------!  TSManager   30-06-2016 09:11:13 272 (0x0110)
Failed to run the action: Copy scripts.

When I check the ZTIGather.log, the drive letter for the DeployDrive differs: if disk is unformatted it's C:. If it's formatted it's D:. I suspect that when MDT tries to find and run LTICopyScripts.wsf, it fails to find it leaving the target with a formatted disk 0, but not able to copy the scripts to it and proceed.

I have not made any changes to the Format and Partition step. Also if I run this from a USB stick with the boot ISO it works (connecting to the DeploymentShare instead of using the USB disk). But we really need the USB Offline Media to work, so switching to only use the boot image on a stick is not a solution. I have also tried recreating a new share, leaving everything as it is and use a vanilla Windows image in a standard Task Sequence.

Any advice on this matter?

UPDATE 1: We have used offline media for 6 years - only offline media. After the new MDT 2013 installation, we started using Boot images from bootable USB sticks, but this is a very new thing for us. We do not have WDS (and pxe boot) - yet. When I deploy from the USB sticks using the deployment boot image, the installation is OK. But all new PC's we receive have unformatted disks, so I need to fix this instead of forcing the techs to run diskpart everytime (or use my intermediary .bat file from the console).

I have uploaded the requested files:

ts.xml

unattend.xml

UPDATE 2: If I create a clean test share, a clean task sequence and a clean media, the error does not go away. So I figured it has to concern the USB Disk. I have tried several USB disks but the problem does not go away. If I deploy this test media from a USB STICK - it works! Our production share is far too big for a USB stick, which is also much slower in data transfer.

So if any suggestions on how this issue can be solved, I would like to hear form you :)

  • Did you regenerate the boot image(s)? Also are you using the latest adk? – Elliot Labs Jul 2 '16 at 19:42
  • Yes, several times on both separate Deployment shares (test and production). Also using latest adk (10.1.10586, ADK for Win 10 Version 151). Also tried several two different USB disks and checked that they are seen as removable/USB. – lyngsie Jul 2 '16 at 20:09
  • Are you able to pxe\wds boot the images and it works then? – Elliot Labs Jul 2 '16 at 20:12
  • Also, can you post your task sequence and unattended.xml? Thanks! (Don't forget to remove any sensitive info) – Elliot Labs Jul 2 '16 at 20:16
  • I have made an UPDATE 1 for your questions. Thanks. – lyngsie Jul 2 '16 at 21:36
1

So after several years with no problems using USB disks, the documentation tells me otherwise (https://technet.microsoft.com/en-us/library/dn781277.aspx?f=255&MSPPError=-2147217396)

When performing a bare-metal, media-based deployment on a Unified Extensible Firmware Interface (UEFI) system using a newer USB flash drive (UFD) that is detected as a “fixed disk” the UFD is detected as Disk 1 (initially assigned the drive letter C) and the internal hard disk is Disk 0. After the internal hard disk is partitioned and formatted, drive letters are reassigned such that the OSDisk is C and the UFD is W. The deployment will fail on the Copy Script step.

So I guess I have to find big and fast flash drives instead. I guess either the new ADK or MDT 2013 U2 is more sensitive to this than earlier versions.

  • MDT 2013 U2 uses Windows PE 10 as the base. I did not realise that you were using portable HDDs as the installation medium. I assumed that it was a Flash drive. I am glad that you found the answer! – Elliot Labs Jul 6 '16 at 14:46
  • I am using a Raspberry Pi 2 as the deployment server (pxe). It is a $35 computer (well they sell the Pi 3 now, same price, just better) and it serves as my PXE server serving up my WIM boot images (using iPXE's wimboot program) with a SAMBA share for the deployment files and Apache to serve the initial boot files faster than tftp. – Elliot Labs Jul 6 '16 at 14:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.