4

I have an instance of Windows Server 2012 R2 running on Amazon Web Services. I am not able to make a TCP connection to the server on any port higher than 6000 for some reason. All ports below 6000 work, however. I've tested this with a short C# program that listens for TCP connections on the specified port and I've been initiating the connections with telnet. In an effort to eliminate possible causes, I've made sure the security group on AWS allows all incoming and outgoing traffic, and Windows Firewall is turned off.

Does anyone have any advice to help me troubleshoot?

  • Please edit your question to show a screenshot of the EC2 instance and it's assigned security group / network acl. Then show a screen shot of the security group and network ACL assigned. It's probably not that if you've checked it, but it's the first place you always have to look, and the best of us overlook things sometimes. – Tim Nov 14 '17 at 3:47
  • I'd be happy to do that for you, except this EC2 instance no longer exists. I gave up on this a long time ago lol. Thanks for your feedback. – portalguy15837 Nov 14 '17 at 16:22
  • Someone has posted a bounty on the question, which is why it was bumped. Suggest you close the question, and the person who gave it a bounty start their own question. – Tim Nov 14 '17 at 18:19
  • I don't know how to close the question. Maybe I haven't earned that permission yet? – portalguy15837 Nov 20 '17 at 15:40
  • Apparently you can't delete questions or answers from the mobile app. My bad. Also, apparently I can't delete a question that has an open bounty. – portalguy15837 Nov 20 '17 at 16:48
1

You may need to add specific rules for the traffic you are attempting.

See Authorizing Inbound Traffic for Your Windows Instances for more information on this.

| improve this answer | |
  • Are you saying that allowing all TCP and UDP traffic in and out on all ports might not be sufficient? Because that would astonish me lol – portalguy15837 Nov 20 '17 at 15:39
  • Also, I was able to see incoming packets with Wireshark, but the program listening on that port wouldn't see the incoming packets, somehow. – portalguy15837 Nov 20 '17 at 15:40
  • This is starting to sound like a firewall issue or specific program settings. It would also help to know what program you are using to access ports in this range. You should add this and the wireshark info/screenshots to your question. – Bill Nov 20 '17 at 16:04
  • I had written a program in C# that listens on a given port, to troubleshoot. Originally I was trying to set up a teamspeak server, which I've done numerous times on other machines, but never on an AMI. – portalguy15837 Nov 20 '17 at 16:16
  • Also, I'll remind you that I turned off Windows firewall completely and I didn't have any third party firewall software installed – portalguy15837 Nov 20 '17 at 16:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.