0

I am new to server administration and have a problem getting new users to be members of a user group when bulk adding new users to Active directory using the dsadd command and Excel of connecting to its home directory
Running the command creates the new users but with a warning, the final parts could not be completed. When each new user logs in they can access their home directory on the file-server but they are not part of their assigned user group, so they cannot access a share drive.

On the GUI manually assigning users to the user group results in access for the user to the share drive.
Using the GUI in creating new users by right clicking on the user group creates the user but they are not members of the user group. My predecessor in the job has disappeared off the grid so no help forthcoming there.

Copy of the command i used

DSADD USER CN=Aisling ,OU=Students,DC=MAIN,DC=Long,DC=Short,DC=Local -UPN Aisling1@MAIN.Long.Short.Local -display "Aisling" -pwd ty9sDUNn -mustchpwd no -hmdir   \\Defiant\Aisling$ -hmdrv H: -memberof CN=Students-group,DC=MAIN,DC=Long,DC=Short,DC=Local

As I said earlier I am new to this business and any help would be appreciated.

4
  • Is the Distinguished Name of the group actually correct? It's right in the root? If not, you have to specify which OU it is in. – MDMarra Jul 6 '16 at 17:39
  • i believe it is correct as i used command dsquery user -name "name of user" on a user added last year to confirm. – Feargal O Shea Jul 7 '16 at 21:51
  • I wasn't talking about the DN of the user, I was talking about the DN a of the group that you're adding them to. It doesn't appear you've added the path to the OU that the group resides in. – MDMarra Jul 7 '16 at 22:58
  • Can you provide the error message you are getting? – humble.adm1n Jul 8 '16 at 13:12
0

Is your group located directly under your domain as the argument for the - memberof parameter suggests or is it within another OU? If so you probably have to edit the distinguished name of the group.

Also is the use of powershell an option?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.