1

I'm in the process of building a training environment in Azure. I'm having some problems with DNS. A basic overview of the environment is as follows

Infrastructure: 1 x Classic Virtual Machine hosting Active Directory Domain Services and the Server side of an application. 1 x RemoteApp Collection with a published client application that connects to a service on the Virtual Machine. 1 x Azure Active Directory

The domain name for the Virtual Machine hosted Active Directory domain is backend.company.com.au and the domain name for the Azure Active Directory is training.company.com.au. Azure ADConnect is running to sync the on-premises accounts to Azure AD. I'm doing this because the RemoteApp configuration I've chosen requires the users have been dirsynced.

The Virtual Machine Server is setting up and connected to the Active Directory Domain backend.company.com.au. It's internal name is server.backend.company.com.au

The Azure RemoteApp is connected to the Azure AD domain training.company.com.au (which has Domain Services enabled)

Overview: Users connect to a client application published by Azure RemoteApp. The client application has been configured to connect to the server using a specific external DNS address - "server.training.company.com.au". The address is fully resolvable in external DNS and the DNS record is hosted by another DNS provider.

The Problem:

The problem I'm running into is that the DNS server the RemoteApp is connecting to doesn't have a record for "server.training.company.com.au" so it fails to connect.

I've found the SOA for the domain is an internal Azure hosted DNS server - it's been automatically assigned the IP address of "10.0.0.6". I've determined this by publishing CMD as a remote app, running "nslookup" then "set querytype=soa" followed by "training.company.com.au".

The Virtual Network has 3 DNS servers set via the new portal (in order): 10.0.0.6, 8.8.8.8, 10.0.0.7, 8.8.4.4. If I reorder this so 8.8.8.8 is first then RemoteApp breaks and throws up an error like "Your Azure RemoteApp collection might have issues because of ADUnAvailable. Fix the problem as appropriate." - trying to connect to a RemoteApp while this error is showing gives me the error "Your computer can't connect to the Azure RemoteApp Gateway"

I'm guessing what I need to do is add a DNS record on this internal azure hosted DNS server (10.0.0.6) but I'm not sure how. I can't connect to the server using the RSAT DNS client as it throws up bad credentials. Do I need to use Powershell?

The client can connect to the server if I use local IP addresses but this won't look as good as using DNS.

What other solutions are there?

I'm sure there's a simple solution but it has me stumped.

Thanks all in advance!!

  • 10.0.0.6 is an internal server and should be some element on your vnet. What is it? – CtrlDot Jul 11 '16 at 3:04
  • Hi CtrlDot Yep that's right. It's an internal IP of one of the prebuilt hosts in my Azure VNET. After some further investigation I've determined the two hosts 10.0.0.6 & 10.0.0.7 are the Domain Controllers that are automatically created when you sign up for a Microsoft Azure Active Directory. Both appear to have the DNS role configured. I originally tried connecting to 10.0.0.6 and it came up with errors saying I couldn't connect. I've just tried 10.0.0.7 via RSAT DNS client and voila it's connected! I added the record and confirmed I was able to connect to server via the remote app! :D – NFreeman Jul 11 '16 at 10:12
0

I must've misread the SOA record when I looked it up earlier.

Turns out the two prebuilt servers (10.0.0.6 and 10.0.0.7) were created when I created my Microsoft Azure Active Directory domain. I connected to the SOA DNS server via RSAT DNS client and was able to add an 'A Record' pointing the local DNS address 'server.training.company.com.au' to the local IP of my azure server.

Problemo solved!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.