1

I am seeing error connecting when I try to connect for conversion of xen-vm to kvm.

I am use virt-manager w/o problems.

Errors seen:

[root@localhost ~]# virt-v2v -v -x -ic "xen+ssh://10.61.0.47" "LAC-Venu" -o local -os /vm-images/
virt-v2v: libguestfs 1.28.1 (x86_64)
[   0.0] Opening the source -i libvirt -ic xen+ssh://10.61.0.47 LAC-Venu
input_libvirt_xen_ssh: source: scheme xen+ssh server 10.61.0.47
libvirt: XML-RPC error : End of file while reading data: sh: nc: command not found: Input/output error
virt-v2v: error: internal error: invalid argument: cannot open libvirt 
connection 'xen+ssh://10.61.0.47'

If reporting bugs, run virt-v2v with debugging enabled and include the complete output:

virt-v2v -v -x [...]
[root@localhost ~]# 

I am seeing following errors.

Please also find the packages installed.
[root@localhost ~]# rpm -qa | grep virt*
libvirt-daemon-config-network-1.2.17-13.el7_2.5.x86_64
libgovirt-0.3.3-1.el7_2.1.x86_64
libvirt-gconfig-0.1.9-1.el7.x86_64
libvirt-daemon-driver-interface-1.2.17-13.el7_2.5.x86_64
virt-v2v-1.28.1-1.55.el7.centos.4.x86_64
libvirt-daemon-driver-storage-1.2.17-13.el7_2.5.x86_64
virt-who-0.14-9.el7_2.1.noarch
libvirt-daemon-driver-network-1.2.17-13.el7_2.5.x86_64
libvirt-1.2.17-13.el7_2.5.x86_64
fence-virt-0.3.2-2.el7.x86_64
redland-virtuoso-1.0.16-6.el7.x86_64
libvirt-python-1.2.17-2.el7.x86_64
libvirt-daemon-driver-nodedev-1.2.17-13.el7_2.5.x86_64
virt-what-1.13-6.el7.x86_64
virtuoso-opensource-6.1.6-6.el7.x86_64
libvirt-glib-0.1.9-1.el7.x86_64
libvirt-daemon-driver-qemu-1.2.17-13.el7_2.5.x86_64
libvirt-daemon-1.2.17-13.el7_2.5.x86_64
libvirt-daemon-config-nwfilter-1.2.17-13.el7_2.5.x86_64
virt-top-1.0.8-8.el7.x86_64
virt-manager-1.2.1-8.el7.noarch
libvirt-daemon-driver-secret-1.2.17-13.el7_2.5.x86_64
libvirt-daemon-driver-nwfilter-1.2.17-13.el7_2.5.x86_64
libvirt-daemon-kvm-1.2.17-13.el7_2.5.x86_64
virt-viewer-2.0-6.el7.x86_64
libvirt-client-1.2.17-13.el7_2.5.x86_64
virt-manager-common-1.2.1-8.el7.noarch
libvirt-gobject-0.1.9-1.el7.x86_64
libvirt-daemon-driver-lxc-1.2.17-13.el7_2.5.x86_64
virt-install-1.2.1-8.el7.noarch
[root@localhost ~]# rpm -qa | grep guest*
qemu-guest-agent-2.3.0-4.el7.x86_64
libguestfs-winsupport-7.2-1.el7.x86_64
libguestfs-tools-1.28.1-1.55.el7.centos.4.noarch
libguestfs-1.28.1-1.55.el7.centos.4.x86_64
libguestfs-tools-c-1.28.1-1.55.el7.centos.4.x86_64
[root@localhost ~]# 
  • 1
    Try to install netcat, as your error message clearly states you don't have nc installed. – Janne Pikkarainen Jul 11 '16 at 7:24
  • i am seeing following [root@localhost ~]# nc --version Ncat: Version 6.40 ( nmap.org/ncat ) [root@localhost ~]# is it not so netcat is installed – Venumadhav Josyula Jul 11 '16 at 7:34
  • is it checking on xenserver for nc ? – Venumadhav Josyula Jul 11 '16 at 9:18
0

Libvirt is trying to start netcat on the remote system, but it is not installed.

This is shown by the error returned from the remote system:

libvirt: XML-RPC error : End of file while reading data: sh: nc: command not found: Input/output error

To fix the problem, install netcat on the remote system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.