0

I developed a simple asp.net webservice that we install in our customers servers in order they can use a mobile app.

I tested the webservice on a windows server 2012 and all was ok. Then I moved to the customer server who has a windows server 2008 r2, I activated IIS, created the new aplication pool enabling 32b apps, mounted the aplication and tried on localhost and all was ok.

It works either on

localhost/service/someservice.asmx

or

127.0.0.1/service/someservice.asmx

But it doesn't work on

customer.dyndns.org/service/someservice.asmx

or

xx.xx.xx.xx/service/someservice.asmx

giving me connection timeout errors.

  • I increased the time out on the web.config
  • I tried a ping to customer.dyndns.org and it was ok
  • I also tried go to customer.dyndns.org/emptyfile.txt just to try it wasn't a "size" problem.
  • I check the firewall and it has the permision for 80 port on http

So... I don't know what else I can do...

We have some webservice like this one working on other servers with windows server 2003, 2008 and 2012 and they work without problem.

0

After a lot of trys we noticed that telnet conection to the webservice was failing. We check the router config and the port 80 was blocked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.