0

I'm using a VPS, and with the Ubuntu 16.04 image I can successfully install bind9, but it doesn't start on boot. There's no named or bind9 under /etc/init.d. Running service bind9 start works as expected. Any ideas?

3

You then may try to manually activate it:

http://manpages.ubuntu.com/manpages/xenial/man8/update-rc.d.8.html

(legacy) Example:

# update-rc.d bind9 enable

On systemd, it would be:

# systemctl enable bind9
  • Thanks a lot! update-rc.d bind9 enable gave me the error update-rc.d: error: cannot find a LSB script for bind9, but systemctl enable bind9 worked as a charm! – ezequiel-garzon Jul 13 '16 at 18:46
2

Just adding onto roothahn's answer as I feel it could use a little explanation, what you will want to do is systemctl enable bind9. Ubuntu 16.04 uses systemd instead of init, so most services are done via systemctl, rather than service and /etc/init.d scripts (which I assume still exist for compatibility reasons).

In terms of starting, restarting and stopping services, it's not a huge change. For example, you would do systemctl restart ssh instead of service ssh restart, systemctl stop mysql instead of service mysql restart, etc. The program name now comes last, which makes it easier to alias (I have :r aliased to systemctl reload-or-restart, so I can just :r ssh to restart sshd)

  • Thanks for the insight! I'll keep that in mind. What puzzles me is that in general doing an apt-get install of a service tends to set it up so that it starts on boot. Maybe it's something Ubuntu will polish in future versions? – ezequiel-garzon Jul 14 '16 at 9:22
  • 1
    Yeah, I find that odd too. That's something strange that I've always known Ubuntu/Debian to do. – apricot boy Jul 14 '16 at 10:52
  • 1
    some services are not boot-enabled by default, that's decided by the package maintainers. btw, you can just use "apt" now (since trusty). – roothahn Jul 14 '16 at 15:31
  • 1
    I also wondered why the manpage I linked to is for xenial, since I was sure it uses systemd now, but I had no xenial by hand to validate – roothahn Jul 18 '16 at 10:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.