1

First of all, here are the specs of the server we are talking about (only the relevant stuff):

  • AMD-6400K with AES-NI
  • 6x3TB WD Red HDDs in Software Raid5 (AES encrypted)
  • 16GB of DDR3 RAM

The overall performance of the HDDs is about 300 - 400MB/s in sequential write/read. The problem is now that it is severly slower when using NFS. It it connected to my PC with a Gigabit network, which should give me a maximum of 120MB/s. But I only come to 17MB/s per second. I once had this server running with Gentoo Linux, Raid5 and NFS and had about 110MB/s. Now it is running with Debian. Unfortunately, I cannot remember my old NFS settings (via Samba the server reaches about 90MB/s btw). This is my current setup:

/nfs/data   bueckstueck01(rw,sync,nohide,no_subtree_check,anonuid=1000,anongid=1000) 192.168.2.0/255.255.255.0(ro,sync,nohide,no_subtree_check,anonuid=1000,anongid=1000) 

and I mount it via:

mount.nfs -o users,exec,rw,wsize=8192,rsize=8192 databueck01:/nfs/data /mnt/data

Can you tell me what I am doing wrong or what you think would be more optimized settings? I am mainly backupping Systems via TAR (single file, sequential write) on this server, so I do not copy multiple small data files on it which would generate a massive overhead. I pipe the systems backup files to tar and direct that directly on the server.

Any help is appreciated!

3

The sync (synchronous) setting is probably your bottleneck. You may consider trying to export with the async (asynchronous) flag, depending on your workload.

Try benchmarking with it.

  • Thank you. I read about that just this moment that this flushes everything directly to physical memory and thus ignoring the cache... I will try this as soon as the current backup sequence is completed. Thanks! – Nidhoegger Jul 14 '16 at 14:29
  • :/. Does not seem to change anything. At first it looks like it is faster, but later on it gets more hangup times o_O. – Nidhoegger Jul 14 '16 at 15:35
  • 1
    Its fascinating. Either there is something severly broken in arch linux or i am just too dumb to use it. With the same paramters on the same machine on gentoo it is rocket fast... – Nidhoegger Jul 15 '16 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.