I'm running Apache on a couple of servers. I'm trying to redirect 1 site from my main server onto another server on my internal network. On my main server I've setup a .conf file master.conf with the following:

ServerAdmin myemail@gmail.com
ServerName mysite.co.uk
ServerAlias www.mysite.co.uk
ProxyRequests Off
<Proxy *>
        Order deny,allow
        Allow from all
ProxyPreserveHost On
ProxyPass /
ProxyPassReverse /
<Location />
        Order allow,deny
        Allow from all

ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined

I believe in order to get Proxies working correctly I also need a .conf file on my slave server with the same name so I have master.conf on my slave with the following:

ServerAdmin myemail@gmail.com
DocumentRoot /var/www/master

I'm getting a 500 Internal Server error. Can you advise

  • have you tried to use your setting in side one virtualhost? – c4f4t0r Jul 14 '16 at 20:59
  • I'm sorry, I'm not sure I understand the question. In both cases above the text is containted within <VitrualHost *:80> </VirtualHost> tags. – HenryM Jul 15 '16 at 6:54
  • if your above test is contained within the virtualhost directive, why you don't include that in your question? – c4f4t0r Jul 15 '16 at 8:59
  • I do apologise. I took it as given – HenryM Jul 15 '16 at 11:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.