3

I have a stage account with files. It is also configured as a share, and is mounted on a Linux server. This part works as expected.

URL to test file in Storage Accounts: https://[CUT].file.core.windows.net/media/test.txt

When attempting to load the URL, it comes up with error 400.

I also created a CDN, with Storage as origin, and /media as the path. Both of the below return 404: http://[CUT].azureedge.net/media/test.txt http://[CUT].azureedge.net/test.txt

I am assuming this is related to incorrect permissions on the storage account, but I am not sure where to change them. I found an option to make a container public for blobs, but not files.

2

You can only access Azure File Storage through SMB or Rest API. That is, without the proper authorization headers, these files are not accessible. If you need anonymous HTTP access or even browser access then you need a blob, not file storage. You can, however, mount this file share to a web server and serve these files through it.

This is also true to work with CDN. You would need to connect the CDN with the web server, not the file storage directly. You also have to wait about 1h for the CDN endpoint to be available otherwise you'd get the 404 error.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.