0

I have an Azure VM with IIS8 and the URL rewrite module installed. I have a single website configured, with both default http (80) and https (443) bindings (for all unassigned traffic).

Both http and https work fine and load the website, however, when I apply some kind of HTTP to HTTPS redirect both http://mydomain and https://mydomain stop working.

I have tried using the standard HTTP Redirect module and I've tried to create a rule using URL Rewrite using the following: http://www.meltedbutter.net/wp/?p=231

Thanks for any ideas:)

  • Does HTTPS work when you don't have the rewrite/redirect in place? – longneck Jul 19 '16 at 16:56
  • yes, both endpoints work as long as I dont have any redirect enabled. I can have the rule enabled in Url Rewrite, site doesn't work...press disable rule and site works again. Same goes for HTTP Redirect module. – user2713516 Jul 19 '16 at 16:59
  • Is there anything logged by the web server? It sounds like it might be a redirect loop, does any error show up in the browser? – James Yale Jul 19 '16 at 17:01
  • the browser just gives me a timeout. Don't find anything useful in the IIS logs unfortunately. – user2713516 Jul 19 '16 at 17:42
0

Still not sure what caused the issue, but at some point I could get the redirect to work on the subdomain, but the virtual dir/application still wouldn't redirect. Eventually decided to delete and recreate the virtual dir. and that 'fixed' the problem

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.