12

I have a dell switch N1548

I have a sonic wall TZ 215

I have followed every blog and forum post i can find online and still cannot get my sonicpoints to hand out addresses from the sonicwall to wireless clients.

DHCP works fine for all others

Here is my running config from the switch

console(config)#show running-config

!Current Configuration:
!System     description "Dell Networking N1548, 6.2.5.3, Linux 3.6.5"
!System Software Version 6.2.5.3
!
configure
vlan 10
exit
vlan 10
name "Wireless"
exit
sntp unicast client enable
sntp server "us.pool.ntp.org"
clock summer-time recurring USA zone "EST"    
clock timezone -5 minutes 0 zone "EST"    
stack
member 1 3    ! N1548
member 2 3    ! N1548
member 3 3    ! N1548
member 4 2    ! N1524P
exit
ip domain-name "corp.haven-oakland.org"
ip name-server "10.2.0.10"
ip name-server "10.2.0.13"
ip host "hvnsw004" 10.2.0.4
interface vlan 1
ip address 10.2.0.4 255.255.255.0
exit
interface vlan 10
ip helper-address 10.2.0.2
exit
ip default-gateway 10.2.0.2
username "admin" password 45f315a95c02cea3a684f9ef61451288 privilege 15 encrypted
ip ssh server
ip ssh port 1025
!
interface Gi4/0/1
description "SonicWALL Uplink X6"
gvrp enable
spanning-tree disable
spanning-tree portfast
spanning-tree cost 20000
switchport mode trunk
switchport general pvid 10
switchport general acceptable-frame-type tagged-only
switchport access vlan 10
switchport trunk native vlan 10
exit
!
interface Gi4/0/2
description "SonicWALL Uplink X6"
spanning-tree disable
spanning-tree portfast
switchport mode trunk
switchport general pvid 10
switchport general acceptable-frame-type tagged-only
switchport access vlan 10
switchport trunk native vlan 10
exit
!
interface Gi4/0/3
description "SonicWALL Uplink X6"
spanning-tree disable
spanning-tree portfast
switchport mode trunk
switchport general pvid 10
switchport general acceptable-frame-type tagged-only
switchport access vlan 10
switchport trunk native vlan 10
exit
!
interface Gi4/0/4
description "SonicWALL Uplink X6"
spanning-tree disable
spanning-tree portfast
switchport mode trunk
switchport general pvid 10
switchport general acceptable-frame-type tagged-only
switchport access vlan 10
switchport trunk native vlan 10
exit
!
interface Gi4/0/5
description "SonicWALL Uplink X6"
spanning-tree disable
spanning-tree portfast
switchport mode trunk
switchport general pvid 10
switchport general acceptable-frame-type tagged-only
switchport access vlan 10
switchport trunk native vlan 10
exit
!
interface Gi4/0/6
description "SonicWALL Uplink X6"
spanning-tree disable
spanning-tree portfast
switchport mode trunk
switchport general pvid 10
switchport general acceptable-frame-type tagged-only
switchport access vlan 10
switchport trunk native vlan 10
exit
!
interface Gi4/0/7
spanning-tree disable
spanning-tree portfast
switchport mode trunk
switchport general pvid 10
switchport general acceptable-frame-type tagged-only
switchport access vlan 10
switchport trunk native vlan 10
exit
!
interface Gi4/0/8
spanning-tree disable
spanning-tree portfast
switchport mode trunk
switchport general pvid 10
switchport general acceptable-frame-type tagged-only
switchport access vlan 10
switchport trunk native vlan 10
exit
!
interface Gi4/0/9
spanning-tree disable
spanning-tree portfast
switchport mode trunk
switchport general pvid 10
switchport general acceptable-frame-type tagged-only
switchport access vlan 10
switchport trunk native vlan 10
exit
!
interface Gi4/0/10
spanning-tree disable
spanning-tree portfast
switchport mode trunk
switchport general pvid 10
switchport general acceptable-frame-type tagged-only
switchport access vlan 10
switchport trunk native vlan 10
exit
!
interface Gi4/0/11
spanning-tree disable
spanning-tree portfast
switchport mode trunk
switchport general pvid 10
switchport general acceptable-frame-type tagged-only
switchport access vlan 10
switchport trunk native vlan 10
exit
snmp-server engineid local 800002a203f8b156838a19
snmp-server community "public" rw
exit

Am i missing something in the switch or could it be the sonicwall?

I have setup the sonicwall according to dell BP and should be working

Thank you if any additional info is needed please let me know.

3

You probably need a helper-address to be defined in the VLAN that's not receiving DHCP. I don't know the exact syntax for your switch, but something like:

ip helper-address 1.2.3.4

Where 1.2.3.4 is the IP of the DHCP server or Sonicwall.

  • I did that, I ran the command "ip helper-address 10.2.0.2" as 10.2.0.2 is the address on my sonicwall – Anthony Fornito Jul 19 '16 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.