1

I am trying to connect pfsense openvpn site to site (peer to peer shared key), but upto now I could not found any traffic between client and server.

openvpn server log

Listening for incoming TCP connection on [AF_INET]192.168.1.5:1194 

openvpn client log

TCP: connect to [AF_INET]192.168.1.5:1194 failed, will try again in 5 seconds: Host is down

apart from firwall rule(WAN + OpenVpn) anything we need to configure in client side.

I followed the same firewall rule for both server and client

firewall -> rule -> WAN

enter image description here

firewall -> rule -> OpenVpn

enter image description here

Note: If you need more info please mention in comment.

when I see the status of the openvpn it is look like below (it is running)

enter image description here

1

Guessing maybe you still have block private networks enabled on WAN? If you're connecting in from 192.168.1.x at least, and WAN is really a LAN in your case.

On an unrelated note, it's always preferable to use UDP for VPNs unless TCP is required for some reason (can't pass UDP between client and server).

| improve this answer | |
  • uncheck the option "Block private networks and loopback addresses" in wan interface, but still the client connection failed – Bilal Usean Jul 21 '16 at 4:26
  • when I use UDP I got error "UDP RemoteLink[undef]", that is why I switch over to TCP – Bilal Usean Jul 21 '16 at 12:15
  • That's just what you see when UDP has no connectivity, same issue, just shows differently. Has nothing to do with TCP vs. UDP. – Chris Buechler Jul 21 '16 at 23:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.