0

I have a nagios server on ubuntu that monitors many other ubuntu servers. They have configured with chef, and they are correctly monitoring things over NRPE (i.e. the NRPE checks work. When something breaks, I get an alert). Everything is fine.

Except that syslog on my monitored hosts has lots of these error messages:

Jul 20 15:07:10 HOSTNAME nrpe[26360]: Error: Could not complete SSL handshake. 5

Every ~5 minutes or so, syslog will get another one of these messages. There is no failing test. I have about 20 monitored hosts, and they all have something like this in their syslog's.

Update: The nagios server's IP address is listed in the allowed_hosts, and has been like that for ages.

How can I stop this message from bring printed into syslog?

3
  • Check if IP address of the nagios server is defined in the nrpe.cfg of the monitored host, Eg: allowed_hosts=127.0.0.1, nagios-server-ip – Federico Sierra Jul 20 '16 at 13:48
  • @FedericoSierra Yes, it's there (see update) – Rory Jul 21 '16 at 9:42
  • im also having this problem now and i tried re-compiling assuring that the ssl option was enabled - still didn't work. – frei Mar 13 '17 at 7:32
1

When you monitor the NRPE port using check_tcp then it cause the error.

The check can not initialize successful connection with NRPE and the client log it in syslog.

0

Now that it's in there, you will need to run: /etc/init.d/nagios-nrpe-server restart

Then it should be working. I would make this comment but I am not yet allowed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.