3

I have just installed Windows Server 2012 R2 Essentials on a new PC.

The server boots to the windows desktop, and a wizard appears asking us to enter an admin username, a domain, and name the PC.

Upon pressing submit, we receive the following error:

enter image description here

This message then re-appears every time the server is rebooted.

I've tried installing all windows updates. I have also tried re-installing and installing all updates before attempting to use the Config wizard. In all cases, we get the same problem.

Looking in the event viewer, it seems the service "Windows Server Essentials Management Service" is crashing:

The Windows Server Essentials Management Service service terminated unexpectedly.  It has done this 2 time(s).  The following corrective action will be taken in 60000 milliseconds: Restart the service.

Any suggestions on how to proceed and complete this configuration wizard?

4

I have managed to resolve the issue, thanks to this blog post: http://techspeeder.com/2014/06/09/an-error-occurred-while-configuring-windows-server-essentials-please-try-again/

The username we had picked for the admin account was "CompanyNameAdmin".

It turns out having the word "admin" or "Administrator" in the username causes it to fail.

Clearly putting a check for that before submitting was too much work for Microsoft :@

  • Weird; this worked for me also (Server 2016 Essentials). – Bill_Stewart Oct 7 '18 at 0:01
0

I have just managed to fix this issue on Essentials 2016 without reinstalling the OS:

  1. Cancel the Wizard when it appears
  2. Stop the Windows Server Essentials Management Service (no need to Disable)
  3. Run the Wizard again manually by going to Run and entering:

C:\Windows\explorer.exe "C:\Windows\System32\EssentialsRoleConfigWizard.exe"

  1. The Wizard will fail again - start the Windows Server Essentials Management Service
  2. Now click Retry and the Wizard should complete

I have only tried this once and I had actually manually installed Active Directory roles by this point, so not sure if this is a pre-requisite, but (somewhat unbelievably!) it worked and the Wizard completed successfully.

EDIT: I had also given ServerAdmin$ Log on as service rights by this point as well (https://blogs.technet.microsoft.com/sbs/2013/12/04/you-may-be-unable-to-run-post-deployment-configuration-wizard-after-you-install-the-windows-server-essentials-experience-role/)

0

I solved the issue by myself in one of my environments by changing the user of the first admin user created during the wizard after the dot so it was not the same as the domain. I explain.

  • The customer was Laundromat Smith.
  • Domain: SMITH
  • User created during the wizard: john.John.smith

Solution was to creare user as johnsmith instead.

To apply, I removed the role Windows Server Essentials Experience. I was asked to perform a clean up. I did it and then I removed the role. Rebbot. Reinstall the role. Started the wizard again and everything worked fine. Hope to have been useful.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.