0

I have 2 Exchange 2013 Standard servers on two different subnets. One is on our local network and the 2nd is on our Cloud provided by our ISP. Adding the 2nd server to DAG went well and seeding the database over was ok too, however, the 2nd server won't failover.

When I try to make the new server as primary and mount the DB I got the following error:

An Active Manager operation failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=1105) Diagnostic context: Lid: 65256 Lid: 10722 StoreEc: 0x451 Lid: 1494 ---- Remote Context Beg ---- Lid: 45120 dwParam: 0x361A1FD Lid: 41344 Guid: 8f10e3e2-f5f8-4c0a-b109-643620473fbc Lid: 35200 dwParam: 0x313C Lid: 50464 StoreEc: 0x451 Lid: 46144 dwParam: 0x361A50A Lid: 34880 dwParam: 0x361AD48 Lid: 59009 StoreEc: 0x451 Lid: 53912 StoreEc: 0x451 Lid: 1750 ---- Remote Context End ---- Lid: 1047 StoreEc: 0x451 [Database: Users, Server: helios.xyz.co.uk]

I have done Test-ReplicationHealth command and I get the following error:

[PS] C:\Users\exadmin\Desktop>Test-ReplicationHealth

Server          Check                      Result     Error
------          -----                      ------     -----
HELIOS          ClusterService             Passed
HELIOS          ReplayService              Passed
HELIOS          ActiveManager              Passed
HELIOS          TasksRpcListener           Passed
HELIOS          TcpListener                Passed
HELIOS          ServerLocatorService       Passed
HELIOS          DagMembersUp               Passed
HELIOS          MonitoringService          Passed
HELIOS          ClusterNetwork             Passed
HELIOS          QuorumGroup                Passed
HELIOS          FileShareQuorum            Passed
HELIOS          DatabaseRedundancy         *FAILED*   There were database redundancy check failures for database 'Ma...
HELIOS          DatabaseAvailability       *FAILED*   There were database availability check failures for database '...

General info:

Helios (server 1): 192.168.0.20 Winterfell (Server 2): 192.168.78.190 DAG IP: 192.168.0.200 Windows 2012 r2 on both and Exchange 2013. There is only 1 NIC on each server (Currently the cloud environment cannot give us a 2nd NIC)

Thanks in advance for your kind support.

---UPDATE---

** Database availability health check failed. Database copy: Mailbox Database 2004460567 Redundancy count: 1

Error: There were database availability check failures for database 'Mailbox Database 2004460567' that may be lowering its availability. Availability Count: 1. Expected Availability Count: 2. Detailed error(s):

    winterfell:
    Database copy 'Mailbox Database 2004460567' is suspended on server 'winterfell'. Reason: None specified.. If you need to perform a switchover of this database, use the Move-ActiveMailboxDatabase cmdlet with the -SkipHealthChecks parameter.

================ Full Copy Status ================


Database Copy : Mailbox Database 2004460567\winterfell


WorkerProcessId : 9860 ActivationPreference : 1 CopyStatus : Suspended Viable : False ActivationSuspended : True ErrorEventId : 0 LastStatusTransitionTime : 21/07/2016 16:48:01 StatusRetrievedTime : 22/07/2016 15:33:19 InstanceStartTime : 21/07/2016 16:48:01 LowestLogPresent : 0 LastLogInspected : 591 LastLogReplayed : 591 LastLogCopied : 591 LastLogCopyNotified : 591 LastLogGenerated : 683 LastLogGeneratedTime : 22/07/2016 15:33:19 LastCopyNotifiedLogTime : 21/07/2016 16:38:53 LastInspectedLogTime : 21/07/2016 16:38:53 LastReplayedLogTime : 21/07/2016 16:38:53 LastCopiedLogTime : 21/07/2016 16:38:53 LastLogInfoFromClusterGen : 683 LastLogInfoFromClusterTime : 22/07/2016 15:33:09 LastLogInfoFromCopierTime : 21/07/2016 16:47:46 LastLogInfoIsStale : False ReplayLagEnabled : Disabled ReplayLagPlayDownReason : None ReplayLagPercentage : 0


Database Copy : Mailbox Database 2004460567\helios


WorkerProcessId : 3396 ActivationPreference : 2 CopyStatus : Mounted Viable : False ActivationSuspended : False ErrorEventId : 0 LastStatusTransitionTime : 01/01/0001 00:00:00 StatusRetrievedTime : 22/07/2016 15:33:19 InstanceStartTime : 17/07/2016 15:42:07 LowestLogPresent : 1 LastLogInspected : 0 LastLogReplayed : 0 LastLogCopied : 0 LastLogCopyNotified : 683 LastLogGenerated : 683 LastLogGeneratedTime : 01/01/0001 00:00:00 LastCopyNotifiedLogTime : 22/07/2016 15:29:02 LastInspectedLogTime : 01/01/0001 00:00:00 LastReplayedLogTime : 01/01/0001 00:00:00 LastCopiedLogTime : 01/01/0001 00:00:00 LastLogInfoFromClusterGen : 683 LastLogInfoFromClusterTime : 22/07/2016 15:33:09 LastLogInfoFromCopierTime : 22/07/2016 15:33:19 LastLogInfoIsStale : False ReplayLagEnabled : Disabled ReplayLagPlayDownReason : None ReplayLagPercentage : 0

  • HI Aniga do you have a File Share Witness configured? if so where is it? – Michael Brown Jul 22 '16 at 14:13
  • Hi Michael, Thanks for coming back to me so quickly - the FSW is on a local server and we don't have a FSW on the cloud - should the FSW be on the cloud? – aniga Jul 22 '16 at 14:58
  • I can't help but think that there's probably more information available in the event logs. Have you looked at them? – joeqwerty Jul 22 '16 at 15:07
  • @joeqwerty I went through the event log and can't seem to see anything that jumps out. – aniga Jul 22 '16 at 15:38
  • @joeqwerty The only error I have seen is updated on my initial question. – aniga Jul 22 '16 at 16:03
0

A second NIC is not going to help unless you have a second connection to the off site server.

Do you have a domain controller in that data centre?

Where is your FSW?

  • Hi @Sembee , Thanks for coming back to be so quickly. Yes, we do have DC in that data centre and the FSW is on a local server. – aniga Jul 22 '16 at 14:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.