0

I am trying to run Apache on Amazon Linux with SSL for my website and I configured all ssl prerequisites. But when I start the Apache it throws the error saying:

Starting httpd: httpd: Syntax error on line 58 of /etc/httpd/conf/httpd.conf: Syntax error on line 1 of /etc/httpd/conf.modules.d/00-ssl.conf: Cannot load modules/mod_ssl.so into server: /etc/httpd/modules/mod_ssl.so: undefined symbol: ap_array_str_contains

conf.modules.d/00-ssl.conf file contains:

LoadModule ssl_module modules/mod_ssl.so

Apache httpd version:

Server version: Apache/2.4.12 (Amazon)

I installed mod_ssl using:

yum install mod24_ssl

I am not aware how to troubleshoot this; I am pretty new to apache.

Please help me if anyone would came across the similar issue?

1

My hunch would be that the SSL module has been compiled against a different version of Apache than the one trying to load it, given that version 2.4.12 of Apache was released in January 2015 and I can see reference to adding the function ap_array_str_contains() to server/util.c in the Apache source only in September 2015.

What does rpm -q mod24_ssl httpd(*) return? They should both realistically have the same version.

(*) Amazon Linux might name their Apache package slightly differently.

  • Thanks for your replay. Is there any possibility to upgrade Apache and install right version of mod24_ssl without affecting the application? – Nagarjuna D N Jul 25 '16 at 16:42
  • Output of "rpm -q mod24_ssl httpd*" mod24_ssl-2.4.18-1.64.amzn1.x86_64 package httpd* is not installed – Nagarjuna D N Jul 25 '16 at 17:27
  • 1
    As suspected, you've somehow managed to install a newer version of mod_ssl for the version of Apache you have. You need to install/upgrade httpd (or that might be httpd24) so they're both version 2.4.18. – bodgit Jul 25 '16 at 18:13
  • Yes, the issue is with Amazon Linux doesn't support mod24_ssl-2.4.12 right now. I just installed httpd24- 2.4.18 then it works. **$ yum --showduplicates list mod24_ssl | expand** Available Packages mod24_ssl.x86_64 1:2.4.18-1.64.amzn1 amzn-main **$ yum --showduplicates list httpd24 | expand** Installed Packages httpd24.x86_64 2.4.12-1.60.amzn1 @amzn-main Available Packages httpd24.x86_64 2.4.18-1.64.amzn1 amzn-main – Nagarjuna D N Jul 26 '16 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.