-1

I have a Lenovo TD200, purchased in around 2009, running RAID 10 with 4 hard drives and Fedora 21. I replaced the backplane alas keep getting the "PD Missing" and "Failed to start operation on drive" messages in the MegaRAID preboot. I tried to force the drive off line per this tutorial packetmischief.ca/2011/03/31/monitoring-direct-attached-storage-under-esxi but it still fails. Some screen shots show the messages including PD Missing.

PD Missing

Failed to start operation on drive

1

So something is faulty. Generic troubleshooting process applies.

Replace/change things one at a time till you find the root cause.

Work carefully, this is RAID. If you get a step out of sequence your data will be gone. Take backups offline to a usb or network drive.

With a RAID controller of this vintage I'd be checking the cache battery, if not already replaced. It will be worn out, and could be causing inconsistent results.

If the fault is consistent - "keep getting" meaning every boot, then problem is more likely software - try updating the megaraid firmware, then drive firmware.

If the fault is random - only some boots or random intervals - the fault is more likely hardware. Not the backplane, you've changed that. The drive would be an obvious one. The controller to backplane cable. The controller.

  • I've tried 2 hard drives & made sure the 2nd was a Lenovo w the same FRU. I don't think the RAID ever had a battery to begin with. Error happens every time I boot into MegaRAID software & the front light stays amber always-never attempts to rebuild. The thread I linked claims u have 2 force the drive off & "fail" it by putting it into the UNCONFIGURED BAD state but it always errors out w "Failed to start operation on drive". If it was a cable issue wouldn't it be affecting other drives? It's always the same. I used the IBM upgrade UpdateXpress for the unit as well & upgraded the MegaRAID CLI. – RobbieTheK Jul 23 '16 at 23:58
0

Turns out I didn't put the new hard drive back far enough in the tray so it wasn't making a good contact with the slot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.