0

How to fix the confliction when install phpmyadmin with PHP 7? I have install PHP 7 and Httpd and last one I want to install phpmyadmin but I got this errors during I've install it.

 sudo yum install phpmyadmin
Loaded plugins: fastestmirror, langpacks
http://repos.fedorapeople.org/repos/jkaluza/httpd24/epel-7/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below knowledge base article 

https://access.redhat.com/articles/1320623

If above article doesn't help to resolve this issue please create a bug on https://bugs.centos.org/

Loading mirror speeds from cached hostfile
 * base: mirror2.totbb.net
 * epel: epel.mirror.angkasa.id
 * extras: centos-hcm.viettelidc.com.vn
 * updates: centos-hcm.viettelidc.com.vn
 * webtatic: sp.repo.webtatic.com
Resolving Dependencies
--> Running transaction check
---> Package phpMyAdmin.noarch 0:4.4.15.7-1.el7 will be installed
--> Processing Dependency: php-mysqli >= 5.3.7 for package: phpMyAdmin-4.4.15.7-1.el7.noarch
--> Processing Dependency: php-mbstring >= 5.3.7 for package: phpMyAdmin-4.4.15.7-1.el7.noarch
--> Processing Dependency: php-gd >= 5.3.7 for package: phpMyAdmin-4.4.15.7-1.el7.noarch
--> Processing Dependency: php-xmlwriter for package: phpMyAdmin-4.4.15.7-1.el7.noarch
--> Processing Dependency: php-tcpdf-dejavu-sans-fonts for package: phpMyAdmin-4.4.15.7-1.el7.noarch
--> Processing Dependency: php-tcpdf for package: phpMyAdmin-4.4.15.7-1.el7.noarch
--> Processing Dependency: php-php-gettext for package: phpMyAdmin-4.4.15.7-1.el7.noarch
--> Running transaction check
---> Package php-php-gettext.noarch 0:1.0.11-12.el7 will be installed
---> Package php-tcpdf.noarch 0:6.2.11-1.el7 will be installed
--> Processing Dependency: php-tidy for package: php-tcpdf-6.2.11-1.el7.noarch
--> Processing Dependency: php-posix for package: php-tcpdf-6.2.11-1.el7.noarch
--> Processing Dependency: php-bcmath for package: php-tcpdf-6.2.11-1.el7.noarch
---> Package php-tcpdf-dejavu-sans-fonts.noarch 0:6.2.11-1.el7 will be installed
---> Package php70w-gd.x86_64 0:7.0.8-1.w7 will be installed
---> Package php70w-mbstring.x86_64 0:7.0.8-1.w7 will be installed
---> Package php70w-mysql.x86_64 0:7.0.8-1.w7 will be installed
--> Processing Dependency: php70w-pdo(x86-64) for package: php70w-mysql-7.0.8-1.w7.x86_64
---> Package php70w-xml.x86_64 0:7.0.8-1.w7 will be installed
--> Running transaction check
---> Package php-bcmath.x86_64 0:5.4.16-36.1.el7_2.1 will be installed
--> Processing Dependency: php-common(x86-64) = 5.4.16-36.1.el7_2.1 for package: php-bcmath-5.4.16-36.1.el7_2.1.x86_64
---> Package php-process.x86_64 0:5.4.16-36.1.el7_2.1 will be installed
---> Package php-tidy.x86_64 0:5.4.16-4.el7 will be installed
--> Processing Dependency: libtidy-0.99.so.0()(64bit) for package: php-tidy-5.4.16-4.el7.x86_64
---> Package php70w-pdo.x86_64 0:7.0.8-1.w7 will be installed
--> Running transaction check
---> Package libtidy.x86_64 0:0.99.0-31.20091203.el7 will be installed
---> Package php-common.x86_64 0:5.4.16-36.1.el7_2.1 will be installed
--> Processing Dependency: libzip.so.2()(64bit) for package: php-common-5.4.16-36.1.el7_2.1.x86_64
--> Running transaction check
---> Package libzip.x86_64 0:0.10.1-8.el7 will be installed
--> Processing Conflict: php70w-common-7.0.8-1.w7.x86_64 conflicts php-common < 7.0
--> Finished Dependency Resolution
Error: php70w-common conflicts with php-common-5.4.16-36.1.el7_2.1.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
2

You need to find a PHPMyAdmin package that doesn't depend on 5.4 version of PHP, but is prepared so that it depends on PHP7.

2
  • How to find that package.Should i uninstall this pages? – Heng Sopheak Jul 27 '16 at 0:53
  • 1
    Google is a good tool for finding such a package. It might be that such a package does not exist. In that case you can try manual installation with the instructions provided in PHPMyAdmin main distribution. – Tero Kilkanen Jul 27 '16 at 8:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.