2

I am trying to upgrade curl but keep on getting this error:

Package: libcurl-7.50.0-1.1.cf.rhel6.x86_64 (CityFan) Requires: libnghttp2.so.14()(64bit)

I am not sure how to get this required package? I'm using city-fan.org-release-1-13.rhel6.noarch repo

4

You're using the third party city-fan repository. This repo has dependencies which are in the EPEL repository, one of which is libnghttp2, so you must have EPEL enabled to use city-fan.

  • This site has instructions on how to enable EPEL: webmaster.net/tutorials/centos/… on CentOS 6 and 7. – Martijn Sep 6 '16 at 7:42
  • @Martijn What's wrong with yum install epel-release? Why does he make it so needlessly complicated? – Michael Hampton Sep 6 '16 at 16:33
  • yum --enablerepo=epel install libnghttp2 -y && yum install libcurl -y && service httpd restart this will download last curl verions from city-fan – Sfblaauw May 8 '18 at 7:31
5

Here is the complete set of commands I executed because it was not clear from the answer of Michael Hampton. Also the link to EPEL install instruction as pointed out were long and unecessary.

yum install epel-release -y
rpm -Uvh http://www.city-fan.org/ftp/contrib/yum-repo/rhel6/x86_64/city-fan.org-release-1-13.rhel6.noarch.rpm
yum update curl

  • The link was broken – xwlee Nov 12 '18 at 6:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.