0

I'm trying to automount an ext4 sparse imagefile on an sshfs mount but it doenst work like its supposed to be :/

I also mount the sshfs mount via autofs and this works like a charm but when I try to add the automount for the imagefile nothing happens...

The mountpoint /storagebox-mnt/storagebox-01 shows up but the /backup mountpoint for the imagefile doesn't so something has to be wrong in my config!

auto.master

/storagebox-mnt /etc/auto.sshfs uid=0,gid=0,--timeout=30,--ghost
/storagebox-nas-backupfs /etc/auto.img --timeout=30

auto.img

/backup -fstype=ext4,defaults,sync,dirsync,commit=1,loop :/storagebox-mnt/storagebox-01/backup.img

auto.sshfs

storagebox-01 -fstype=fuse,rw,nodev,nonempty,allow_other,reconnect,max_read=65536 :sshfs\#user@example.com\:/

If I run automount in the foreground no error message shows up...

edit#1: fixed the lookup errors by commenting out some includes in the default /etc/auto.master file but the result is the same! The sshfs mount works and the loop image mount doesn't.

sudo automount -f -v

Starting automounter version 5.1.1, master map /etc/auto.master
using kernel protocol version 5.02
lookup(dir): dir map /etc/auto.master.d missing or not readable
lookup(file): failed to read included master map dir:/etc/auto.master.d
lookup(file): failed to read included master map auto.master
mounted indirect on /storagebox-mnt with timeout 30, freq 8 seconds
ghosting enabled
mounted indirect on /storagebox-nas-backupfs with timeout 30, freq 8 seconds
0

The problem was the uid=0,gid=0 options in the auto.master file... The sshfs was mounted via the root account and the image file obviously wasn't... I changed the options to my useraccount for both mounts and now its working.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.