So, the situation is as follows. Our production servers are the most important servers being affected but this is happening randomly. I can not build a pattern for servers that are being affected to ones that arent. It seems to be completely random.

We do reboots once a month on our servers. Every time we reboot, random servers will lose their STATIC a record in DNS. It will propagate almost instantly too. We will then have to either manually enter another A record in DNS or do a ipconfig /registerdns and wait 15 minutes or so.

All of our servers are on a VLAN with no DHCP, and they have statically assigned everything. The option on the NIC to enabled registering of the address in DNS is enabled.

We have scavenging, but its every 7 days (of anything older than 7 days) and the cycle was started on a Monday, and we restart on Thursday. What do you think I should do?

  • bump. do i need to provide more info? – colbyt Aug 2 '16 at 17:35

Did you disable the "DHCP Client" service on these servers?

The DHCP client service is the service that registers the computer in DNS.

Here is the description of the service:

Registers and updates IP addresses and DNS records for this computer. If this service is stopped, this computer will not receive dynamic IP addresses and DNS updates. If this service is disabled, any services that explicitly depend on it will fail to start.

  • Will that make it so it doesn't try to renew its DNS record? Isnt that bad? Ill try it and let you know though – colbyt Jul 28 '16 at 19:44
  • I just realized you werent telling me to try disabling it, but simply asking if it was already. it was enabled on the servers with and without issues. I just checked a few – colbyt Jul 28 '16 at 19:50
  • That DHCP client service should be set to 'automatic' if you want machines to update and register their records. If you disable it then the machine won't be able to update or register in DNS automatically. I would not recommend disabling it. – tunafreedolphin Jul 28 '16 at 19:52
  • They are set to auto – colbyt Jul 28 '16 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.