1

I am setting a value in /sys/block/xxx/queue/max_sectors_kb in order to try and resolve an iSCSI IO site limit bug and have found the value to revert to its default 32767 as soon as the iSCSI disk is used.

I am setting both manually and with udev rules but the same thing happens, my value of 512 gets replaced again with 32767 which causes IO errors and failure when I am creating a new VM on the iSCSI disk.

8
  • 1
    Can you please add the debian version?
    – Alex H
    Aug 9, 2016 at 9:05
  • Can you check what VPD block limits your device reports, using sg_inq /dev/sda -p bl (for the correct device) What type of iSCSI target is this? Is it possible that you are hit by the bug fixed here: marc.info/?l=linux-scsi&m=142958776223667&w=2
    – BeerSerc
    Aug 9, 2016 at 11:30
  • How do you create the VM? E.g. Openstack, vmware?
    – 030
    Aug 9, 2016 at 21:55
  • Did you check the log?
    – 030
    Aug 9, 2016 at 21:55
  • I will check the VPD command today. The target is a HP P2000 iSCSI SAN. Aug 11, 2016 at 8:37

1 Answer 1

0

This issue has been seen before:

https://forum.proxmox.com/threads/troubles-iscsi-and-max_sectors_kb.25750/

It seems it can be solved on a udev script but you must consider:

  1. udev script might interpret redirection symbol ">" as a command parameter; then just call a regular bash script from the udev script and set the value there.

  2. when the disk is "plugged/first used" the value is created then the corresponding udev script must be sure that it does its job "after" the disk connection process is finished.

reference: https://www.linux.org.ru/forum/admin/12155562

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.