0

I have two machines on a local network

192.168.1.71 has ssh port open

$ netstat -ntlp | grep LISTEN

port open --> tcp6 0 0 :::22 :::* LISTEN

Lines in /etc/ssh/sshd_config

ListenAddress ::

ListenAddress 0.0.0.0

# SCENERIO

$ ssh foo@localhost --> connects successfully

$ ssh foo@192.168.1.71 --> (from same server 192.68.1.71 timesout)

$ ssh foo@192.168.1.71 --> (from server 192.168.1.90 timesout)

Is there a setting in the ssh_config file I must add like a new "ListenAddress" or something?

Almost thinking this is could be a firewall issue within the network and nothing to do with the ssh_config file on the server. Thanks in advance!

Diego

Tried the commands that you all recommended, below are the results

sudo ufw status [sudo] password for dango: Status: active

To Action From -- ------ ---- 22/tcp ALLOW Anywhere
22 ALLOW Anywhere
22/tcp (v6) ALLOW Anywhere (v6)
22 (v6) ALLOW Anywhere (v6)

22/tcp ALLOW OUT Anywhere
22/tcp (v6) ALLOW OUT Anywhere (v6)

diego@ubuntu3:~$ sudo iptables -L INPUT -n Chain INPUT (policy ACCEPT) target prot opt source destination
ufw-before-logging-input all -- 0.0.0.0/0 0.0.0.0/0
ufw-before-input all -- 0.0.0.0/0 0.0.0.0/0
ufw-after-input all -- 0.0.0.0/0 0.0.0.0/0
ufw-after-logging-input all -- 0.0.0.0/0 0.0.0.0/0
ufw-reject-input all -- 0.0.0.0/0 0.0.0.0/0
ufw-track-input all -- 0.0.0.0/0 0.0.0.0/0

  • Are you using ubuntu's firewall? To check run: ufw status it should show Status: inactive if it is disabled. If it is enabled run ufw allow ssh to enable ssh through. – David Aug 1 '16 at 20:00
  • ....or, more generally, do you have some firewall rules that are denying your inbound SSH access on 192.168.1.71? You can check it by yourself (on any distribution) with: iptables -L INPUT -n. Let us know... – Damiano Verzulli Aug 1 '16 at 20:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.