0

Here is my situation, I have a router R1 whose external IP address is 11.11.2.1. I have another router R2 whose external IP address is 5.5.2.1.

enter image description here

I am running eBGP on R1 and R2. However, I cannot ping R2 from R1 and R1 from R2. How can I make them to ping each other? I know that they are in a different subnet. But, this can be a practical case where I don't want to force the external IP address to match the subnet of the other router interface.

1

With out "disable connected check command" also this scenario worked for me.Added a static route to neighboring route and achieved neighbor ship.

R1#
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 1.0.0.0 mask 255.255.255.0
 network 1.1.1.0 mask 255.255.255.0
 network 2.2.2.0 mask 255.255.255.0
 neighbor 11.11.2.1 remote-as 100
 no auto-summary


FastEthernet0/0            5.5.2.1       
Loopback0                  1.1.1.1        
Loopback2                  2.2.2.2       
!
!
ip route 11.11.2.0 255.255.255.0 FastEthernet0/0
!
!
!
R1#show ip bgp summary 

Neighbor        V          AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
11.11.2.1       4        100      19      19        3    0    0 00:17:05        0


!!
!!
!!


router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 5.5.2.1 remote-as 200
 no auto-summary

! ! FastEthernet0/0 11.11.2.1
! !
! ip route 11.11.2.0 255.255.255.0 FastEthernet0/0 !

Neighbor        V          AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
5.5.2.1         4        200      20      20        1    0    0 00:17:11        2
0

eBGP requires neighbours to be directly connected in the same subnet by default. If your two BGP neighbours are in different subnets then you will need to use an intermediate router in order to route BGP packets between the subnets.

Static routes and the multihop BGP command would be required. You should take a check over some BGP documentation.

  • Yeah makes sense -- so the basic of router is that we need to connect two routers on the same subnet otherwise - arp resolution will fail. At the bottom, it is finally L2 which has to make ethernet device resolution no matter what protocol you run. I tried the mask of 0.0.0.0 which is invalid. – dexterous_stranger Aug 3 '16 at 22:56
-1

R1:

ip route static 5.5.2.0 24 serial1/0

R2:

ip route static 11.11.2.0 24 serial1/0

Ensure you can ping R1 <--> R2

There after:

R1:

bg 100
neighbor 5.5.2.1 remote as 200
neighbor 5.5.2.1 disable-connected-check

R2:

bgp 200
neighbour 11.11.2.1 remote as 100
neighbor 11.11.2.1 disable-connected-check

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.