14

Windows 8 / 8.1 / 10 has this feature called "Fast Startup" (or "fast boot", "hybrid statup", "hybrid shutdown", and so on...) which doesn't actually shut down the computer when you tell it to do so, instead putting it in a sort of hybernation, in order to speed up boot time.

Although this might seem nice at first view, it has several known and ugly side effects:

  • It can seriously screw up on some systems (possibly when using old/incompatible drivers or BIOSes), resulting in a system crash at boot time and a subsequent forced full boot (this I witnessed personally on several different systems... and good luck if you are also using mirrored dynamic disks, which will always undergo a full resync after a system crash).
  • It does hell to the processing of some group policies, which require an actual system restart in order to be applied.
  • Last but not least, it has been known to render Wake-On-Lan unusable; this is the problem I'm currently facing after an upgrade to Windows 10 of several Windows 7 PCs which used to WOL quite fine, and now just don't anymore.

For these and other reasons, I'd like to be able to manage Fast Startup using Group Policies; however, the only policy I could find about this (Computer Configuration\Policies\Administrative Templates\System\Shutdown\Require use of fast startup) can only be used to force the use of Fast Startup, but not to disable it: its description explicitly states that if you disable or do not configure this policy setting, the local setting is used.

Thus, my question: how can I disable Fast Startup using a group policy?

15

It looks like there is no Administrative Template for managing this setting; as documented, Computer Configuration\Policies\Administrative Templates\System\Shutdown\Require use of fast startup can only be used to enforce it, not to disable it (WTF?!? It's already enabled by default... they could at least have gone a bit further and turn this setting into a true on/off switch!).

The only available way to disable Fast Startup (outside of using the GUI) is by setting the following Registry key to 0:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Power\HiberbootEnabled

This can be done using Group Policy Preferences and it effectively disables Fast Startup; of course, setting it to 1 would instead enable it.

And yes, disabling Fast Startup fixes the problem of Wake-On-Lan not working.

0

You might be able to set it via GPP. I believe it's key is: HKLM\System\CurrentControlSet\Control\Session Manager\Power\HiberbootEnabled

0

I know this is an old post. But I was having the same issues. It does work to just disable hibernation as well. "powercfg -h off"

0

The Group Policy documentation for Computer Configuration\Policies\Administrative Templates\System\Shutdown\Require use of fast startup is incorrect - disabling this value DOES have the required effect, at least in my testing (Windows 10 Build 1511). I would check in your environment - seems to be a documentation error.

  • Just tested on Win 10 1709. Doesn't work. – Copy Run Start Dec 6 '17 at 23:36
0

I agree with Minkus that by Disabling GPO Computer Configuration\Policies\Administrative Templates\System\Shutdown\Require use of fast startup does set the following registry key HKLM\SOFTWARE\Policies\Microsoft\Windows\System\HiberbootEnabled=0 (REG_DWORD) but that doesn't seem to Disable Fast Startup in my testing. It does seem like a bug since the only way to properly Disable Fast Startup is by setting the Regkey: HKLM\SYSTEM\CurrentControlSet\Control\SessionManager\Powerfix\HiberbootEnabled=0

protected by Community Mar 5 '18 at 7:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.