0

i have an environment running MDT 2013 and i have multiple different models for (dell/lenovo) desktops and laptops.

i captured an image and it runs well on all the computers except a specific lenovo models which are (L440, L450, T440, T450) i downloaded the SCCM package and injected the drivers into the Out of box drivers and created a selection profile to assign the correct drivers for these models. error occurs "windows could not configure one or more system components" i searched deeper and the only option i found is to open the regedit and then go to (HKLM_System_setup_status_childcompletition_setup) and change the value to (3) instead of (1) it worked also when i uploaded only the Ethernet and chipset drivers only on the MDT, but it is a big hassle to install each driver manually.

please help

  • What OS are you trying to deploy? – Elliot Labs Aug 2 '16 at 21:21
  • Windows 7 Enterprise and Professional – MoustafaBorhan Aug 3 '16 at 8:49
  • Have you tried deploying the image without customizations? E.g. from a DVD but using MDT to add the items post install? Also are you using the latest MDT update? It should be update 2 – Elliot Labs Aug 3 '16 at 13:37
  • yes and it works normally however the problem seems in the drivers – MoustafaBorhan Aug 10 '16 at 13:41
  • Mount the WIM image you're trying to deploy and then mount the registry (the system hive, located at \Windows\System32\config\SYSTEM) and edit the key manually. Unload the hive and then commit the image upon unmounting it. Deploy and profit! (If this works then I will write it as an answer with screenshots) – Elliot Labs Aug 10 '16 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.