0

I have some problem with my Squid proxy. I cannot start the proxy after the proxy was down. From what I know, since yesterday I did not touch any Squid configuration. Then this morning I came to the office and it looked like it was down. Refer the cache.log below:

2016/08/03 10:24:47| Unlinkd pipe opened on FD 16
2016/08/03 10:24:47| Swap maxSize 3584000 + 32768 KB, estimated 602794
objects
2016/08/03 10:24:47| Target number of buckets: 30139
2016/08/03 10:24:47| Using 32768 Store buckets
2016/08/03 10:24:47| Max Mem  size: 32768 KB
2016/08/03 10:24:47| Max Swap size: 3584000 KB
2016/08/03 10:24:47| Local cache digest enabled; rebuild/rewrite every
3600/3600 sec
2016/08/03 10:24:47| logfileOpen: opening log /var/log/squid/store.log
2016/08/03 10:24:47| Rebuilding storage in /var/spool/squid (DIRTY)
2016/08/03 10:24:47| Using Least Load store dir selection
2016/08/03 10:24:47| Current Directory is /
2016/08/03 10:24:47| Loaded Icons.
2016/08/03 10:24:47| Accepting proxy HTTP connections at
192.168.120.104, port 8080, FD 18.
2016/08/03 10:24:47| HTCP Disabled.
2016/08/03 10:24:47| WCCP Disabled.
Can't locate NTA/database/TechDb.pm in @INC (@INC contains:
/opt/nta/perl/lib/perl5 /etc/perl /usr/local/lib/perl/5.10.1
/usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5
/usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl
/usr/local/lib/perl/5.10.0 .) at
/opt/squid_auth/script/squid_techdb_digest_auth.pl line 9.
BEGIN failed--compilation aborted at
/opt/squid_auth/script/squid_techdb_digest_auth.pl line 9.
2016/08/03 10:24:47| Ready to serve requests.
2016/08/03 10:24:47| WARNING: digestauthenticator #2 (FD 8) exited
2016/08/03 10:24:47| WARNING: digestauthenticator #3 (FD 9) exited
2016/08/03 10:24:47| WARNING: digestauthenticator #4 (FD 10) exited
2016/08/03 10:24:47| Too few digestauthenticator processes are running
FATAL: The digestauthenticator helpers are crashing too rapidly, need help!

Squid Cache (Version 2.7.STABLE9): Terminated abnormally.
CPU Usage: 0.028 seconds = 0.024 user + 0.004 sys
Maximum Resident Size: 22224 KB
Page faults with physical i/o: 0
Memory usage for squid via mallinfo():
        total space in arena:    2924 KB
        Ordinary blocks:         2854 KB      5 blks
        Small blocks:               0 KB      0 blks
        Holding blocks:           780 KB      3 blks
        Free Small blocks:          0 KB
        Free Ordinary blocks:      69 KB
        Total in use:            3634 KB 98%
        Total free:                69 KB 2%
Can't locate NTA/database/TechDb.pm in @INC (@INC contains:
/opt/nta/perl/lib/perl5 /etc/perl /usr/local/lib/perl/5.10.1
/usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5
/usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl
/usr/local/lib/perl/5.10.0 .) at
/opt/squid_auth/script/squid_techdb_digest_auth.pl line 9.
BEGIN failed--compilation aborted at
/opt/squid_auth/script/squid_techdb_digest_auth.pl line 9.
Can't locate NTA/database/TechDb.pm in @INC (@INC contains:
/opt/nta/perl/lib/perl5 /etc/perl /usr/local/lib/perl/5.10.1
/usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5
/usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl
/usr/local/lib/perl/5.10.0 .) at
/opt/squid_auth/script/squid_techdb_digest_auth.pl line 9.
BEGIN failed--compilation aborted at
/opt/squid_auth/script/squid_techdb_digest_auth.pl line 9.

Please advise.

0

The Perl module NTA/database/TechDb.pm is missing and is causing the program to exit.

CPAN and Google can't find anything about it.

What OS are you using Squid on? Is this something proprietary? Why is there stuff under /opt/nta and /opt/squid_auth on your system? It's not standard. Your system is configured in some unusual way.

  • Thanks for reply...really appreciate... NTA/database/TechDB.pm is my company DB.. I'm using debian Wheezy for OS. Yea,It's not a standard configuration...Please advice.Thanks. – Kamal Aug 3 '16 at 6:57
  • @Kamal You need to get a hold of that perl module and any of it's dependencies and put it in your @INC path. Start by just searching the filesystem on the server for that file (TechDB.pm). – Ryan Babchishin Aug 3 '16 at 8:39
0

This issue has been resolved. It was not so much that the module was not in the path, but more that the recent engine update overwrote permissions for the TechDb.pm module. The issue was that the squid service running as "proxy" could not read the perl module as when it had been updated, it went back to the "scans:techdata" default. As a result, I have commited the module to SVN to keep it the same as other servers, meaning the permissions will not change from the "proxy" user.

Thanks

  • Can someone tag it as resolve?..I didn't manage to do it...thanks.. – Kamal Aug 4 '16 at 3:51
0

The better way to resolve this would be to use group membership the way it is supposed to be used in POSIX systems.

  • remove the cache_effective_group setting from squid.conf

  • add the proxy user as a member of techdata group (to read the module).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.