0

We've been using Exchange 2010 for all possible roles for a long time. Now we've got ourselves new Exchange 2016 installation within same site, same domain, in order to migrate mailboxes there and get rid of old Exchange 2010.

One of few problems I've run into is that there was no mail flow between two servers. I can move mailboxes between two as much as I want, but when I send email to mailbox on other server - no success.

I've managed to half-solve the issue by adding receive connector on 2010. Now I was able to send mail from 2016 to 2010. Connector is like that:

listen on port 25 on primary interface
accept mail from 2016 ip
authentication with TLS and Exchange Server
Exchange Server permission group

But I don't know how to configure Exchange 2016 to be able to receive mail from 2010. I've messed around with it's default Frontend connector for a bit (tried to make it look basically the same) but no success. In fact I'm not even sure if receive connector is what I need. That's the reply I've got for messages I send from 2010 to 2016:

Diagnostic information for administrators:
Generating server: oldserver.contoso.com
newservermailbox@contoso.com
#550 4.4.7 QUEUE.Expired; message expired ##
Original message headers:
Received: from oldserver.contoso.com ([172.22.223.2]) by oldserver.contoso.com
 ([172.22.223.2]) with mapi id 14.03.0123.003; Thu, 28 Jul 2016 17:20:32 +0600
Content-Type: application/ms-tnef; name="winmail.dat"
Content-Transfer-Encoding: binary
From: Old Server Mailbox <oldservermailbox@contoso.com>
To: New Server Mailbox <newservermailbox@contoso.com>
Subject: Test08
Thread-Topic: Test08
Thread-Index: AdHowgsxCxzf+vHaQi2Wb9IRsLMA1A==
Date: Thu, 28 Jul 2016 17:20:31 +0600
Message-ID: <A8216FA42D4DBF4BA9F4F78BD4B88C396ECDF84F@oldserver.contoso.com>
Accept-Language: en-US, kk-KZ
Content-Language: ru-RU
X-MS-Has-Attach:
X-MS-TNEF-Correlator: <A8216FA42D4DBF4BA9F4F78BD4B88C396ECDF84F@oldserver.contoso.com>
MIME-Version: 1.0
X-Originating-IP: [172.22.232.48]

So any wisdom about how to make them work together is welcome.

0

You don't have to add a receive connector to either server for email to flow correctly and there should be no reason to change the connectors on the Exchange 2016 machine either. It should work straight out of the box.

However if the default receive connector is not at the default configuration then it will stop.

The most common reason I see for email flow to stop is for the FQDN on the receive connector to be changed from the default of the server's real name (so changed to mail.example.com, instead of server1.domain.local).

Ensure that you have Exchange Server Authentication enabled on both sides.

There isn't enough in what you have posted to know the exact error. If you send an email to a user on the other server, look in the queue viewer to see what the error is.

0

Apparently, it's a bug in Exchange. I wasn't receiving email on 2016 because nothing was listening on 25 port - service were simply making attempts to start and were crashing over and over.

This bug is specific to Exchange 2016 installation on localized Windows Server 2012R2 version (RU). I was there in Ex2016 RTM, was fixed in CU1 and reappeared in CU2.

So I had to install en-US language pack on Windows and reinstall Exchange to get around it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.