0

I have a cluster on GKE with many pods and persistent disks (PD) and cannot deploy anymore.

pod failed to fit in any node fit failure on node (XX): MaxVolumeCount

The issue should not affect me because I have a 2-code machine and Google recently raised the persistent disk limit to 64:

https://cloudplatform.googleblog.com/2016/04/enhanced-persistent-disks-for-Google-Compute-Engine-better-Kubernetes-and-Docker-support.html

The problems seems to be a env var in the master that says KUBE_MAX_PD_VOLS = 16. The issue seems to be fixed but since I have a hosted master I cannot find the way to change the env var.

https://github.com/kubernetes/kubernetes/issues/24317#issuecomment-214556057

So the question is:

How can I change an env var in a GKE master?

  • An answer to a similar question has been posted on this thread. – Kamran Dec 10 '16 at 22:54
  • I saw the discussion was carry out also here and there has been some progress but not an ideal solution yet. – Carlos Mar 20 '17 at 23:52
1

Google Container Engine is a managed environment so it won't allow you to set env vars on the master.

Options to move this forward will be:

  • Run your own Kubernetes cluster on GCE instead of GKE.
  • Submit a feature request to GKE to provide this feature under 'Container Engine' component.
  • The Issue that you posted is still open, so you might wait for a complete solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.