0

I've tried to create a private/public key using putty and puttygen although I'm still seeing the password prompt when launching putty with the specified private key in the connection/ssh/auth option. Both the client and server are Windows machines.

On my client machine I ran puttygen and entered a password, then saved the private key to my client machine's c:\key\privatekey.ppk. I then selected all the public key string and copied it to my buffer. I then logged into the server and created a file c:\user\testuser\.ssh\authorized_keys and pasted the public key into it and saved.

whilst on the server I tested I was assuming the right user by launching cmd.exe from the start->run dialog and the prompt was c:\users\testuser>

leaving the server, back on the client I launched putty and specified the private key in the connection/ssh/auth option of putty and then entered the ip address into the hostname: 1.2.3.4

in the prompt I entered the username: testuser (and I also tried domain\testuser) but the server said 'server refused our key' error

Is there something I'm missing/ doing wrong?

Thanks for any help

0

The following:

"c:\user\testuser.ssh\authorized_keys and pasted the public key into it and saved it. "

You are doing that on some Linux/UNIX machine or on Windows server itself?

Windows does not have a native SSH server, so you can't login to windows using SSH keys.

If you are indeed trying to do this on a Linux/UNIX Server, that should work unless the ssh_config has been adjusted to deny key authentication.

Sorry, the server and client information is just not sounding right in your question above. It will help if you clarify once more. Thanks.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.