I'm trying to set up a imaging environment. The idea is to use DISM to apply WIM images (Windows 10 Pro) over the network.

I am able to boot into Windows 10 PE. I have network connectivity via DHCP.

When I try to map the network share using net use i: \\server\share I get:

System error 58 has occurred. 
The specified server cannot perform the requested operation.

If I try to map it with net use i: \\server\share /user:user password where user is a system user, it works.

The share is is completely public. I am able to map the share with no credentials on 4 other Windows machines. (2x Win7, 2x Win8).

The server is Ubuntu 14.04 running Samba. 4.3.9-Ubuntu.

My /etc/samba/smb.conf looks like this:

    workgroup = WORKGROUP
    security = user
    server string = Imaging Server
    dns proxy = no
    follow symlinks = yes
    wide links = yes
    unix extensions = no
    log file = /var/log/samba/log.%m
    max log size = 1000
    guest account = nobody
    encrypt passwords = true
    map to guest = bad user

    comment = images
    path = /share
    browsable = yes
    guest only = yes
    read only = no
    writable = yes
    public = yes
    create mask = 0664
    directory mask = 0775

/share is owned by nobody:nogroup

Any ideas would be appreciated.


3 Answers 3


That's just how Windows 10 connects to anonymous shares: it checks some username and password to see if it is able to log in, and if so it allows an anonymous connection.

Apparently whatever part hides this from the user didn't make it into the PE build, so just specify a dummy username and password, like /user:user pass.

If you need to provide actual credentials you can specify a user and password like this: /user:DOMAIN\user *. The star will make sure you are prompted for your password instead of having to specify it on the command line.

  • I was also trying to configure pxe server for win10 installation for many days. just forget to add "password" to net share command. "net use t: //server/share /user:username password" and getting the error. The share got mounted after adding password. Thanks to above answer user232591.
    – Kishor
    Feb 18, 2018 at 15:07

Doesn't seem to be a Linux issue, seems to be Windows 10 as I have the same issue. The fix I have researched seems to be this... example... net use z: //192.168.02/tftp \root: /root password

I have not tried this will be attempting it at work tomorrow.


I tried the same on a number of occasions. I actually never made it work using a completely anonymous connection but just supplying any user / pass combination seems to work out with shares that are configured the way yours are.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.