2

Have encountered this issue now on 3 servers, 2 were in pre-deployment stage, but this one happened after a crash.

Environment: VMWare ESXI 6.0u2 running on Dell Poweredge R510 Server with E1000E Adapter.

After a recovery from a crash server is working for four days, noticed today in troubleshooting a different issue, we were unable to ping the server or connect via RDP.

Logged into the server using the Vsphere Client, and Windows is not activated, and network access is in yellow.

Call MS Support, as Product Key is unable to be activated, and we get it going in about 15 minutes. Reboot the Server and Windows is now genuine, but am still seeing no network access.

Having seen this before on 2 other servers, I knew I could set the adapter to DCHP and it worked. I then created a new identical adapter in VSphere (E1000E) again, and gave it the static settings, but it would not connect.

Results of ipconfig /all

Ethernet adapter Ethernet 0:

Connection-specific DNS Suffix . :
Description. . . . . . . . . . . : Intel(R) 82574L Gigabit Network Connection
Physical Address. . . . . . . . .: 00-0C-29-20-08-91
DHCP Enabled. . . . . . . . . . .: No
Autoconfiguration Enabled . . . .: Yes
IPv4 Address. . . . . . . . . . .: 192.168.15.26(Preferred)
Subnet Mask . . . . . . . . . . .: 255.255.255.0
Default Gateway . . . . . . . . .: 192.168.15.1
DNS Servers . . . . . . . . . . .: 192.168.0.26
                                   127.0.0.1
NetBIOS over Tcpip. . . . . . . .: Enabled

I have tried the registry DefaultGateway empty fix, it was empty but deleting it, and rebooting did not work, and editing it did not work.

Have attempted editing it multiple times in the GUI, and tried setting it manually via netsh as well.

Any help or insight would be greatly appreciated, Cam


EDIT:

PS C:\...> route print
Interface List
 24...00 0c 29 20 08 91 .....Intel(R) 82574l Gigabit Network Connection #3
   1......................................Sotware Loopback Interface 1
IPv4 Route Table
Active Routes:
Network Destination  Netmask        Gateway            Interface  Metric
0.0.0.0                0.0.0.0     192.168.15.1 192.168.15.26  266
127.0.0.0             255.0.0.0        On-link     127.0.0.1    306
127.0.0.1         255.255.255.255  On-link         127.0.0.1    306
127.255.255.255   255.255.255.255  On-link         127.0.0.1    306
192.168.15.0      255.255.255.0    On-link        192.168.15.26 266
192.168.15.26   255.255.255.255    On-link        192.168.15.26 266
192.168.15.255   255.255.255.255   On-link        192.168.15.26 266
224.0.0.0              240.0.0.0   On-link        127.0.0.1     306
224.0.0.0              240.0.0.0   On-link        192.168.15.26 266
255.255.255.255   255.255.255.255  On-link        127.0.0.1    306
255.255.255.255   255.255.255.255  On-link           192.168.15.26 266
Persistent Routes:
  Network Address                    Netmask    Gateway Address    Metric
                   0.0.0.0                       0.0.0.0          192.168.15.1     Default
                   0.0.0.0                       0.0.0.0          192.168.15.1     Default
IPv6 Route Table
Active Routes:
  If Metric    Network Destination                  Gateway
  1       306  ::1/128                                       On-Link 
  1       306  ff00::/8                                       On-Link 
Persistent Routes:
   None

I then followed what @mzhaase said to do and change from an E1000/E to a VMXNET driver, and added an additional adapter. The VMXNET does the same thing, and allows internet on a non .26 ip and on dhcp, but will not stick on .26

I also attempted creating a new install on a new vhd in vmware, and it also had the issue with .26 I reverted the vhd setup and put back in the original install.

At this point I think the issue is either in VMWare (6.0u2) or at our firewall PFSense. I'm going to work with my network engineer, to see if we can troubleshoot the firewall today.

  • 1
    Your primary DNS server is on a different network, why is that? You have localhost as your secondary DNS server, why is that? – joeqwerty Aug 8 '16 at 22:33
  • It's the domain controller at a remote site. The main dns is the main DC, and the remote dc, serves dns. – Cam Aug 9 '16 at 0:13
  • Have you any other nics enabled, what is the default route? please provide the output of: route print and also what happens if you ping the default gateway? – Joeme Aug 9 '16 at 5:32
  • @Cam, don't put information in comments, put it in the question. And please paste it as text. – Daniel Aug 10 '16 at 8:51
  • There is a known issues with the E1000 adapter and Windows Server, have you tried the VMWare adapter? – mzhaase Aug 10 '16 at 9:01
1

So the resolve was a known Ghost Adapter Issue in VMWare:

Resolve was to log into the server,

Run CMD

Enter: set devmgr_show_nonpresent_devices=1

Go into Control Panel -> Network & Internet -> Network Sharing Center and you should see atleast 2 adapters.

One of them will have the held onto ip settings, change the adapter to dhcp, and then change the semi-working adapter to the static ip address and I was back in business.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.