0

Might be a stupid question, but how can I get an _amd64.deb package version of a mod_pagespeed release prior to the current stable/beta versions - i.e. release 1.11.33.0-beta - https://github.com/pagespeed/mod_pagespeed/tree/1.11.33.0

I need to install mod_pagespeed on my Debian Wheezy server and the current version doesn't support it (libc6 version dependency is now 2.14 and Wheezy has 2.13). Building mod_pagespeed from source or somehow updating libc6 wouldn't be a great option on this important production web server.

I'd love to simply grab and dpkg the latest version that didn't yet require glibc >= 2.14 and would dpkg on Debian Wheezy 7.0 without throwing a dependency error like:

sudo dpkg -i mod-pagespeed-stable_current_amd64.deb
Selecting previously unselected package mod-pagespeed-stable.
(Reading database ... 40509 files and directories currently installed.)
Unpacking mod-pagespeed-stable (from mod-pagespeed-stable_current_amd64.deb) ...
dpkg: dependency problems prevent configuration of mod-pagespeed-stable:
mod-pagespeed-stable depends on libc6 (>= 2.14); however:
Version of libc6:amd64 on system is 2.13-38+deb7u7.

The release notes say the last version that supported this setup is just a couple of releases back - the glibc 2.14 requirement is in place as of v 1.11.33.1-stable in May 2016, so 1.11.33.0-beta should do the trick.

Is there an archive of the older .deb packages out there somewhere? Or a way to reference the version in the URL structure when using wget - i.e. https://dl-ssl.google.com/dl/linux/direct/mod-pagespeed-????_amd64.deb

1

[[ IMPORTANT UPDATE: If you're serving secure HTTPS pages on your server (we are not), the below won't be an acceptable solution for you due to a High Severity security issue that was resolved in mod_pagespeed release 1.11.33.2 , but if you're sticking with HTTP, it will work just fine. - read more on this here and at developers.google.com/speed/pagespeed/module/release_notes#release_1.11.33.2-beta ]]

I dug around and came up with a solution:

It turns out there's a mod_pagespeed amd64 deb package archive at pkgs.org :

https://pkgs.org/debian-ubuntu/google-mod_pagespeed-amd64/

Instead of 1.11.33.0-beta which was available and in theory should have worked, I had to go back to 1.9.32.14 because anything newer still threw this error during dpkg:

dpkg: dependency problems prevent configuration of mod-pagespeed-beta:
mod-pagespeed-beta depends on libc6 (>= 2.14); however:
Version of libc6:amd64 on system is 2.13-38+deb7u7.

So by trial and error, eventually I ran this and it worked :)

sudo wget "http://dl.google.com/linux/mod-pagespeed/deb/pool/main/m/mod-pagespeed-stable/mod-pagespeed-stable_1.9.32.14-r0_amd64.deb"
sudo dpkg -i mod-pagespeed-stable_1.9.32.14-r0_amd64.deb
sudo apt-get -f install
sudo service apache2 restart

I now have mod_pagespeed running on Debian Wheezy. I know it's a deprecated version, but still ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.