0

I have a Group Policy Object that installs a software (.msi file):

Deployment type: Assigned
Deployment source: \\server\folder\installer.msi
Uninstall this application when it falls out of the scope of management: Disabled
Ignore language when deploying this package: Disabled
Make this 32-bit X86 application available to Win64 computers: Enabled
Include OLE class and product information: Enabled

Required upgrade for existing packages: Enabled
Packages that this package will upgraded: GPO
None
Categories: None
Transforms: None

On PC boot, this installs just fine for the scope (one location). It sits at "Please wait..." in Windows for 7min and installs.

But then on a reboot, it goes through all that again even though the software is already installed. Since this is a healthcare organization, the wait time isn't really viable.

Why is it installing the software over and over?

When I look at Event Viewer for an example PC, I see this:

The assignment of application Installed Agent from policy Software_Agent_Install succeeded.
The reinstall of application Installed Agent from policy Software_Agent_Install succeeded.
Changes to software installation settings were applied successfully.

(No changes were made to this GP policy since the 9th which was the day the policy was created, and this software reinstall occurred today. No changes to the MSI file since 7/27/2016)

  • For the record, this is one of many reasons that experienced admins try to avoid Group Policy software installation. Causes many more problems than it solves. Use an actual configuration management system, rather than this mess. – HopelessN00b Aug 11 '16 at 15:49
  • Slightly different question, but the answer is applicable serverfault.com/questions/568418/… – Drifter104 Aug 11 '16 at 16:42
  • Agree with HopelessNoob, I normally use gpp to create a scheduled immediate task to run a script that checks see if the software is installed and if not, will install the program. Works much better because the program can be run while no one is logged in. – Joe Aug 11 '16 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.