I have a file system bug/error. My dedicated server cannot start. OVH started my dedicated server in rescue mode, and:

root@rescue:~# parted /dev/sda 'print'
Model: ATA SAMSUNG MZ7LM240 (scsi)
Disk /dev/sda: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End    Size   Type     File system     Flags
 1      1049kB  240GB  240GB  primary                  boot
 2      240GB   240GB  536MB  primary  linux-swap(v1)

So the problem, don't have file system in sda, and in sdb.

All data very-very important, so I must save them. Please, help me, how can I create a file system in the disks, and restore everything?

I tried testdisk command, but i could not restore the file system.

When I try mount i got this message:

root@rescue:/mnt# mount /dev/sdb1 /mnt/
mount: unknown filesystem type 'linux_raid_member'

root@rescue:/mnt# mount /dev/sda1 /mnt/
mount: unknown filesystem type 'linux_raid_member'

And the fdisk write this:

root@rescue:/mnt# fdisk -l

Disk /dev/sda: 223.6 GiB, 240057409536 bytes, 468862128 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xc6522a8b

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1  *         2048 467810303 467808256 223.1G 83 Linux
/dev/sda2       467810304 468856831   1046528   511M 82 Linux swap / Solaris

Disk /dev/sdb: 223.6 GiB, 240057409536 bytes, 468862128 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xa398617a

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sdb1  *         4096 467810303 467806208 223.1G fd Linux raid autodetect
/dev/sdb2       467810304 468856831   1046528   511M 82 Linux swap / Solaris

Disk /dev/md1: 446.1 GiB, 479033556992 bytes, 935612416 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 524288 bytes / 1048576 bytes

root@rescue:~# mount /dev/md1 /mnt/
mount: /dev/md1 is write-protected, mounting read-only
NTFS signature is missing.
Failed to mount '/dev/md1': Invalid argument
The device '/dev/md1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

When I check dmesg:

root@rescue:~# dmesg | tail
[    8.724614]  md1: unknown partition table
[   10.430793] systemd-journald[389]: Received request to flush runtime journal from PID 1
[   18.468492] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[   18.468494] 8021q: adding VLAN 0 to HW filter on device eth1
[  492.873958] nf_conntrack: automatic helper assignment is deprecated and it will be removed soon. Use the iptables CT target to attach helpers instead.
[  492.942832] ip_set: protocol 6
[  517.742940] ip_set: protocol 6
[ 1599.096427] EXT4-fs (md1): VFS: Can't find ext4 filesystem
[ 1602.001332] EXT4-fs (md1): VFS: Can't find ext4 filesystem
[ 3396.499044] ip_set: protocol 6

I got e-mail from OVH:

Here are the details of this operation: Diagnosis interface boot (rescue) Date 2016-08-11 19:55:22, elyess H made Diagnosis interface boot (rescue): Here are the details of the operation performed: The server gets stuck during the boot phase, with the message: (error: unknowk filesystem) A restart on the standard OVH kernel ('netboot') does not correct the situation.

Actions: Rebooting the server to "rescue" mode (Linux)

result: Boot OK. Rescue mode accessible.

recommendations: Configuration / error to be corrected by the customer

So the PROBLEM: I lost my filesystem, and I cannot start, and I cannot mount the disk. I have RAID-1 in the dedicated server, but I cannot mount /dev/md1.

How can I restore the file system? How can I mount the disk? How can I start the system? I think if I solve the filesystem, i will can start the system.

Thank you for your help!

closed as off-topic by Chopper3, Basil, Iain, HopelessN00b, mdpc Aug 12 '16 at 14:12

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions should demonstrate reasonable business information technology management practices. Questions that relate to unsupported hardware or software platforms or unmaintained environments may not be suitable for Server Fault - see the help center." – Chopper3, Basil, mdpc
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    Easy - build the server from scratch and restore your last backup. – Chopper3 Aug 12 '16 at 11:00
  • 1
    By restoring from your last backup – Chopper3 Aug 12 '16 at 11:19
  • 1
    Have you tried restoring from your latest backup? – Basil Aug 12 '16 at 11:53
  • 3
    It's important that you understand that what you've done is staggeringly unprofessional and you've then come a place specifically for professionals to ask for hep - imagine if you'd walked into a airline pilot lounge and said "I appear to have sawn my plane's wings off - halp!" – Chopper3 Aug 12 '16 at 12:05
  • 5
    I'm voting to close this question because the OP needs tech support and not Q&A. – Iain Aug 12 '16 at 13:28

In short way, you're in serious troubles. From mdstat you posted as comment, I can see you have RAID-0, not RAID-1 configuration, see:

root@rescue:~# cat /proc/mdstat Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4] [multipath] [faulty] md1 : active raid0 sda1[0] sdb1[1] 467806208 blocks 512k chunks unused devices:

Raid-0 is stripped raid - you're using all capacity of all of your drives and data are saved across all disks, but you have no redundancy for case of failing device.

And this is what happened to your server. One of your disks failed. It is common thing in server environment. But because you have only RAID-0 configuration, you're screw and all of your data are lost.

Now it depends on value of data saved on your server. You can try to talk with OVH to power off your server, take those drives out and send it to some company specialized to rescue data from failed drives. It is expensive service and you have no guarantee they will restore 100% of your data. It will definitely take days or weeks to restore it and your server will be offline for this time.

Another way is to restore your backups and accept damage.

No another way here, I'm sorry.

  • what makes you think one disk failed? – Uwe Burger Aug 12 '16 at 13:31

ok try the fsck.ext4 with the alternate superblock like sugested.

  • ok try the alternate superblock with fsck as sugested. – Uwe Burger Aug 12 '16 at 13:17
  • I tied alternate superblock , but i got same message. – Maróthy Zsolt Aug 12 '16 at 13:35
  • ok this is bad. get images of both disks with dd over ssh. ssh root@rescuesystem dd if= – Uwe Burger Aug 12 '16 at 13:39
  • ssh root@rescue dd if=/dev/sfa – Uwe Burger Aug 12 '16 at 13:41
  • 6
    @MaróthyZsolt you need to back away from the keyboard, you're making matters much much worse. – Chopper3 Aug 12 '16 at 14:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.