0

I ran into an interesting problem where I ran robocopy to copy hundreds of GB of files to a remote location for a test lab, the vpn dropped several times, copies retried - due to bandwidth limitations it was stopped, etc. All things that can explain why this happened.

After getting to the point robocopy said the directories matched with no errors we had problems with several of the files.

  • Maybe you should submit a trouble report to Robocopy and see what they have to say. Perhaps there's a validation option that you could have checked or something similar. – Julie Pelletier Aug 13 '16 at 5:42
0

To fix I ran rsync to Linux with -c (checksum compare of files instead of other algorithms). This resulted in thousands of files mismatching and being updated.

I couldn't find a windows only way to fix this easier given the bandwidth restrictions.

rsync --inplace --cza --progress //server/share/dir/* rsync://server/share/dir/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.