-1

I have problem when send email to a domain(ex: example.com). in my server's logs always show error :

Fail-info: Unable to connect to zzz.zzz.zzz.zzz : Connection timed out
Status:PROCESSED - RELAY
MBox:INBOX

I have checked Mx Record of the domain in http://mxtoolbox.com and show 3 mx record like this :

Pref    Hostname            IP Address          TTL     
5       mx5.example.com     xxx.xxx.xxx.xxx     11 hrs
10      mx10.example.com    yyy.yyy.yyy.yyy     11 hrs
20      mx20.example.com    zzz.zzz.zzz.zzz     11 hrs 

When i TES SMTP of the mx record only pref 5 is working but my email server always send mail to pref 20

Is possible to force my email server to send email from mx record pref 5 ? and how to configure it ?

btw sorry for my bad english & this is my frist time configuring mail server

UPDATE : My mail server use https://www.axigen.com

SOLVED thanks to @Ryan Babchishin Solved this with configure axigen which support relaying,

  1. Go to Message Acceptance Settings > Advanced Setting > Add Acceptance/ Routing Rule

  2. With condition :

    a. Conditions

    a.1. Recepient domain is mx5.example.com

    b.2. Relaying email

    b. Actions :

    b.1. Hostname/ip : mx5.example.com port 25

    b.2. Setting (unchecked) Allow StartTLS

Save Configuration


2

Are you saying mx20 doesn't respond but mx5 does? And mx5 is the highest priority MX for the domain? And that mail is always being sent to mx20 instead of mx5? That shouldn't happen. And, a failed connection to one MX should result in an attempt to connect to the next MX in the domain. The mail should go through eventually.

I don't think it's really under your control unless you want to do something weird.

Something weird:

I think it would be possible to setup mx5.example.com as a relay for mail destined to example.com in your mail server configuration. You don't say what SMTP software you're using, so I can't tell you how. If you do this, there will be no backup MX (mx10, mx20) if something goes wrong with mx5.

I believe with Postfix this is where your reading starts: http://www.postfix.org/transport.5.html

  • ok thanks for the clue :) i have solved this with configure relay email : when i send email to example.com i change to mx5.example.com in acceptance & routing before i read your comment i add an ip not domain when relaying btw we use axigen.com mail server, – Mr.EchoAnd Aug 15 '16 at 4:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.