1

I am using Windows 2012 server R2's WDS to deploy win10 images to client PCs which are combinations of HP ProBook 450, 430, and HP ProDesk 400 G1. Recently I bought a few HP ProDesk 600 G2 and now my perfectly working WDS image does not like new HP desktop.

I connected the new PC through LAN cable to the network and performed a network boot followed by selecting the right boot image. Then selected the install image and got the "setup is starting" screen. After a few minutes of thinking, I got "WdsClient: an error occurred while obtaining an IP address from the DHCP server. Please check to ensure that there is an operational DHCP server on this network segment."

I checked DHCP lease details and the client PC was able to receive an IP address through DHCP server.

By the way, DHCP and WDS are on the same subnet.

After doing a bit of research, I found out that, it is a problem with the ethernet driver. So I am now trying to add the network driver package to boot image, hoping that I could load the network driver during PE if it is the driver issue.

I can select network driver package as below

AddDriverPackage

Then it gives "Dism host servicing process has stopped working"

After closed the dialog box, then it displays below "operation failed" error with "class not registered"

OperationFailed

However, as error states that I thought the problem is with "Netwew01[x64]" "file name Netwew01.INF" and next time when I run it, I did not select the "networkw01.INF". Then it came back with the same unresponsive error followed by same "class not registered" error but pointing to a different driver set ("ansmw60e.INF"). However, I tried again removing second driver set and the same thing happened with a different driver set.

Could someone please help me with this issue by either fixing initial issue or the second part?

  • So, is this a boot issue or a driver integration issue? Thanks! – Elliot Labs Aug 15 '16 at 17:46
  • It seems like, issue is relating to ethernet driver not loading to boot image – Sammy Aug 16 '16 at 2:14
  • Have you tried using a tool like MDT to deploy your images? You might have better luck with the driver integration. – Elliot Labs Aug 16 '16 at 12:27
1

I went through this same issue with a Windows 10 Pro deployment through WDS. I determined it was an ethernet driver issue as well and was not able to install the driver through WDS, just like you. I had to add the driver package to the offline image using DISM.

Follow the instructions under "To add drivers to an offline image by using DISM" and use /forceunsigned because, even though the driver is from HP (in my case Dell), still force it as unsigned.

At an elevated command prompt, locate the Windows Assessment and Deployment Kit (Windows ADK) servicing folder, and type the following command to retrieve the name or index number for the image that you want to modify. For example, type:

Dism /Get-ImageInfo /ImageFile:C:\test\images\install.wim

An index or name value is required for most operations that specify a WIM file. For a VHD file, you must specify /Index:1.

Mount the offline Windows image. For example, type:

Dism /Mount-Image /ImageFile:C:\test\images\install.wim /Name:"Windows Drive" /MountDir:C:\test\offline

Add a specific driver to the image. For example, type:

Dism /Image:C:\test\offline /Add-Driver /Driver:C:\drivers\mydriver.inf

Multiple drivers can be added on one command line if you specify a folder instead of an .inf file. To install all of the drivers in a folder and all its subfolders use the /recurse option. For example,

Dism /Image:C:\test\offline /Add-Driver /Driver:c:\drivers /Recurse

To install an unsigned driver, use /ForceUnsigned to override the requirement that drivers installed on X64-based computers must have a digital signature. For example,

Dism /Image:C:\test\offline /Add-Driver /Driver:C:\drivers\mydriver.inf /ForceUnsigned

Review the list of third-party driver (.inf) files in the Windows image. Drivers added to the Windows image are named Oem*.inf. This is to guarantee unique naming for new drivers added to the computer. For example, the files MyDriver1.inf and MyDriver2.inf are renamed Oem0.inf and Oem1.inf.

For example, type:
Dism /Image:C:\test\offline /Get-Drivers 

Commit the changes and unmount the image. For example, type:

Dism /Unmount-Image /MountDir:C:\test\offline /Commit

From: https://technet.microsoft.com/en-us/library/hh825070.aspx

  • However, I can proceed up to install an unsigned driver step and then get a " Dism Host servicing process has stopped working" with options > check online for a solution, close the program, and debug the program. On the elevated powerShell, I get Error: 0X0000135 "an error occurred while attempting to start the servicing process for the image located at E:\wds\offline. for more info review the log file". In the log file not much luck relating to the error. – Sammy Aug 16 '16 at 2:09
  • What version of DISM are you using? If you are running DISM on, say, Windows Server 2012 to add drivers to your Windows 10 image, you'll get a DISM error. DISM cannot work with a newer version since the older version doesn’t know what newer version is. – Art.Vandelay05 Aug 16 '16 at 14:40
  • If you aren't running DISM on a Windows 10 computer, you can run DISM from the Windows 10 ISO\DVD. From an elevated CMD prompt (or eleveated Powershell) %PathToWindowsInstallMedia%\Sources\dism.exe /image:%ImageMountDirFromAbove% /add-driver /driver:%PathToDriversFolder% /recurse /forceunsigned – Art.Vandelay05 Aug 16 '16 at 14:49
  • And of course, save (commit) your changes! – Art.Vandelay05 Aug 16 '16 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.