1

So I've been having a bit of an issue here, and I'm having a lot of trouble determining what it is; I'm trying to configure backups for one of our servers, and whenever I attempt to do one of said backups, it fails with error 517 in event viewer, and gives the message "the backup operation has failed with following error code '0x807800C5' (There was a failure in preparing the backup image of one of the volumes in the backup set.). Please review the event details for a solution, and then rerun the backup operation once the issue is resolved." The details section doesn't give me much detail at all, and otherwise, I can't tell what the issue is. What I do think it is, is windows, and not the filer, but I can't be sure. Here's what I do know;

-The Netapp filer is an older filer, and doesn't support the SMB3 protocol- This, I've heard, could be an issue, but I think this is unlikely as I can back up to it in some cases...

-When I first configured the backup, windows was able to backup the system state, and the C: drive, but would fail immediately after. I figured, at the time, this could be due to the configuration of the volume I was backing up to on the filer, so I erased the volume and CIFS share and made a new one. I still encountered the same error, however now it fails on the C: drive but is successful on the drives that it failed on before.

-I've worked a lot with Data ONTAP, and my knowledge of this system tells me these failures may be spawned from the fact that windows doesn't like interacting with flexible volumes, which is what the backup volume is- Unfortunately the aggregate that this volume is on occupies the entire shelf save for 2 spares, so if I want to make a traditional volume that might work better with Windows, I'll have to blow away the entire shelf attached to that node of the filer, which takes a bit of work- thus why I don't really want to do that until I know it's the issue. Currently the filer nor the shelf attached to it have any data on them, so this is okay to do.

-VSS was generating warnings in event viewer, informing me that it can't resolve a non-important account with status "1376." I removed the accounts that were raising this warning from the registry key detailed in the warning, and VSS started to generate information events instead of warnings that seemed to indicate proper functionality of VSS, however this didn't effect my ability to back up the server, or not.

The system I'm trying to back up is a HP G8 server, not a virtual machine, running Windows Server standard 2012 R2, and the total mass of storage that I'm backing up comes within the neighborhood of 800GB. The filer system I'm trying to back up to is a Netapp FAS2020, running Data ONTAP 7.3, with two nodes installed- The secondary one carries a DS14mk2, which is the physical system I'm trying to backup to. It doesn't include any of the filer's internal disks, those are managed by the partner node, if that matters.

Anyone know anything about this? Or experienced anything like it before? Any help would be greatly appreciated, thanks :)

  • The server doesn't see the share as a volume or an aggregate, it just sees a CIFS target. – Basil Aug 16 '16 at 11:41
  • This is true, however the size of a flexible volume is not necessarily definite and windows doesn't like this. – Ben Franchuk Aug 16 '16 at 14:21
  • 1
    Ontap reports the size of the volume to the client if it's a volume that's mapped. If it's a qtree with a quota, it reports the size of the quota. I think you're barking up the wrong tree here- your issue likely has nothing to do with the volume, but the protocol probably matters. – Basil Aug 18 '16 at 0:03
0

In the end, I configured the Filer with iSCSI, which works well and allows me to backup successfully. I'd still like an answer otherwise, if anyone knows.

  • 2
    Since your backup procedure works perfectly using block-level iSCSI protocol and fails when trying to work using CIFS target it is most likely the problem of Data ONTAP CIFS realization and the incompatibilities between SMB that Windows 2012 R2 requires and the once that Data ONTAP actually offers. Most probably reservation or authorization issues I think. – Net Runner Aug 24 '16 at 11:34
  • This is what I concluded myself. – Ben Franchuk Aug 27 '16 at 23:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.