5

I have a new php 5.6 installation and get the following error from my application:

Fatal error: Call to undefined function xml_parser_create()

But libxml seems to be OK? phpinfo about libxml is:

libXML support  active
libXML Compiled Version     2.9.1
libXML Loaded Version   20901
libXML streams  enabled 

I installed already:

    sudo apt-get install php-xml-parser 
    sudo apt-get install libapache2-mod-php5
  • Ubuntu 14.04 (yes I know its old but not changeable at the moment).
  • Apache 2.4.7
  • PHP Package is from ppa:ondrej/php (5.6.24-1+deb.sury.org~trusty+1)

1 Answer 1

11

First check installed extensions in php with following command

php -m

After enter check Do you find follwing xml list?

xml
xmlreader
xmlwriter

if not then add following line

apt-get install php5.6-xml

After doing so, make sure to restart appache

service apache2 restart

Hope this will help you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .