I have a PERC H330 RAID controller with 3 Seagate ST4000NM0034 drives, and the controller does not appear to be recognizing the drives. It does not show up in the CTRL+R screens anywhere and I'm getting concerned the cabling or card is bad. Any suggestions?

  • 3
    Call Dell support.
    – user143703
    Aug 18, 2016 at 5:07
  • Can't afford it. Aug 19, 2016 at 16:31

1 Answer 1


If you don't see the Ctrl+R screen, that's not going to be a cabling issue. A PERC should still show up in the BIOS regardless of whether any physical disks are connected/detected. Check your card's seating, verify you're using a PCI slot that can provide enough power, maybe check whether the card is even compatible with the server you've put it in... standard PCI card troubleshooting. Wouldn't hurt to heed @yoonix's words and just call Dell support if that's an option for you (if you have a warranty currently active).

  • CTRL+R does show up, the PDs do not. Aug 18, 2016 at 14:44
  • Ah, misunderstood your wording. Try reseating the cabling to the H330? Make sure the drives are getting power? What type of server is this in?
    – JimNim
    Aug 18, 2016 at 15:23
  • It's in a custom built home server. I'm guessing part of the problem is the card isn't on a real server motherboard/cpu combo and it just straight up doesn't like the mobo, because I'm at a total loss for why the drives won't even spin up. I've tried switching cables, reseating, just about everything. Aug 19, 2016 at 16:31
  • Moving this to comment, accidental extra answer: "What type of cable are you connecting with? If you're able to boot into the PERC BIOS, that should get you past any possible issues with the system BIOS since the H330 is just communicating directly with the drives at that point." Response was "It's a breakout cable that has one connector on one end and 4 flying leads on the other end that terminate to the SAS combined power/data. The power leads plug into the leads from the PSU."
    – JimNim
    Aug 20, 2016 at 17:14
  • 1
    Are you using SAS or SATA drives in the server? Have you tried powering up with just one drive connected to make sure the others aren't just pulling too much power?
    – JimNim
    Aug 20, 2016 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.