0

I have a PXE boot server (everything is inside vmware) with a label that is configured as follows:

label 2g
        kernel centosX64_7.2
        append text nofb load_ramdisk=1 initrd=centosX64_72.img network ks=http://kickstart/ks/centos72.cfg inst.repo=http://myrepo/centos7.2

Here is what I do in the PXE menu: enter image description here

Then it proceeds with it's routine and then dracut kicks in downloading squashfs file (I suspect this might have something to do with my problem): enter image description here

And when finally the it grabs and installs all the packages that it needs to and I log in into the system there is no IP0 in my cmdline file. If I reboot the system and pass it with grub options as usual afterwards it does appear though. Any suggestions are highly appreciated.

____UPDATE____

So I tried what @dragz suggested. There is no way to use arrow keys. Nothing happens when I try to do that, so the only thing available is to use the actual boot codes. I tried to change the label to:

label 2g
        kernel centosX64_7.2
        append text nofb load_ramdisk=1 initrd=centosX64_72.img network ks=http://kickstart/ks/centos72.cfg inst.repo=http://myrepo/centos7.2 **IP0=10.0.12.120** 

Just to see if you might be right, but the boot option still does not get passed. However, if I just do 2f IP0=... (for cenntos6.7) it does work as expected.

1

When you enter 2g at the boot: prompt it selects the 2g menu entry which contains all the predefined boot parameters (and ignores the rest of the line after 2g). If you want to change the boot parameters, scroll down to the menu entry you want with your arrow keys and press e to edit the boot entry manually.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.